xfce-base/xfwm4: Bump to 4.12.4
authorMichał Górny <mgorny@gentoo.org>
Thu, 16 Mar 2017 09:26:40 +0000 (10:26 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 16 Mar 2017 09:27:10 +0000 (10:27 +0100)
xfce-base/xfwm4/Manifest
xfce-base/xfwm4/xfwm4-4.12.4.ebuild [new file with mode: 0644]

index 527f8c3c3c7239a88e785197d667c885795f8afb..717be075ce7a3277a3fe7404834377cb84636bf2 100644 (file)
@@ -1 +1,2 @@
 DIST xfwm4-4.12.3.tar.bz2 1191929 SHA256 f4a988fbc4e0df7e8583c781d271559e56fd28696092f94ae052e9e6edb09eac SHA512 96fcc76fc640027883a7a3373836565987b1d3d4e61fb40aa7e2f990a8140d92cf66171fb4517368faba45c9083a3ad19f589d59b07a55c3417aaaca87e408d7 WHIRLPOOL 0fd8e058694cb2f6486bc59443e00d8ed42ebd9dabe39775451d94c14c7e2ea87a520edea26e3bc7033fa1d95aa0ca1a6b2045eca9a1c9d8ecfb67f1ef88b0a8
+DIST xfwm4-4.12.4.tar.bz2 1208874 SHA256 fa74048a75649a6e92df763a3cfb706d3fed1e1a6adf567f6693325a5a6efb36 SHA512 a33530b08f094456c45ad7c627ba34d3772eaeacdc9f422a3a54a16194d494cb1d6798122398d917fb8bc970db7e1184d9dc8edefc365dacc86de22be397b43d WHIRLPOOL fa26fd4bf758b7c57964956809e9036320aaecc43fad2a0aa3fdca2bd83dda7edc1884fa86ed7f1ab12b94066f4bc729d5aa4e001121f813f128ebb4cc3c3018
diff --git a/xfce-base/xfwm4/xfwm4-4.12.4.ebuild b/xfce-base/xfwm4/xfwm4-4.12.4.ebuild
new file mode 100644 (file)
index 0000000..4e3a1f5
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Window manager for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="dri startup-notification +xcomposite"
+
+RDEPEND="dev-libs/dbus-glib:=
+       >=dev-libs/glib-2.20:=
+       >=x11-libs/gtk+-2.24:2=
+       x11-libs/libX11:=
+       x11-libs/libXext:=
+       x11-libs/libXrandr:=
+       x11-libs/libXrender:=
+       x11-libs/pango:=
+       >=x11-libs/libwnck-2.30:1=
+       >=xfce-base/libxfce4util-4.10:=
+       >=xfce-base/libxfce4ui-4.11:=
+       >=xfce-base/xfconf-4.10:=
+       startup-notification? ( x11-libs/startup-notification:= )
+       xcomposite? (
+               x11-libs/libXcomposite:=
+               x11-libs/libXdamage:=
+               x11-libs/libXfixes:=
+               )"
+# libdrm: only headers are used
+# libICE/liBSM: not really used anywhere but checked by configure
+#   https://bugzilla.xfce.org/show_bug.cgi?id=11914
+DEPEND="${RDEPEND}
+       dev-util/intltool
+       sys-devel/gettext
+       x11-libs/libICE
+       x11-libs/libSM
+       xfce-base/exo
+       virtual/pkgconfig
+       dri? ( >=x11-libs/libdrm-2.4 )"
+
+DOCS=( AUTHORS ChangeLog COMPOSITOR NEWS README TODO )
+
+src_configure() {
+       local myconf=(
+               $(use_enable dri libdrm)
+               $(use_enable startup-notification)
+               --enable-xsync
+               --enable-render
+               --enable-randr
+               $(use_enable xcomposite compositor)
+       )
+
+       econf "${myconf[@]}"
+}