dev-perl/Cache-Memcached: -r bump for EAPI7
authorKent Fredric <kentnl@gentoo.org>
Sat, 9 May 2020 02:19:31 +0000 (14:19 +1200)
committerKent Fredric <kentnl@gentoo.org>
Sat, 9 May 2020 02:20:34 +0000 (14:20 +1200)
- EAPI7
- Fix depends
- Prune empty variable assignments and unused vars
- Reflect upstream license as much as possible re bug #721730
- Annotate testing requirements
- Parallel tests

Bug: https://bugs.gentoo.org/721730
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/Cache-Memcached/Cache-Memcached-1.300.0-r2.ebuild [new file with mode: 0644]

diff --git a/dev-perl/Cache-Memcached/Cache-Memcached-1.300.0-r2.ebuild b/dev-perl/Cache-Memcached/Cache-Memcached-1.300.0-r2.ebuild
new file mode 100644 (file)
index 0000000..63dd6a3
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DORMANDO
+DIST_VERSION=1.30
+inherit perl-module
+
+DESCRIPTION="Perl API for memcached"
+HOMEPAGE="http://www.danga.com/memcached/ https://metacpan.org/release/Cache-Memcached"
+# Bug: https://bugs.gentoo.org/721730
+LICENSE="|| ( Artistic GPL-1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+RDEPEND="
+       virtual/perl-Encode
+       virtual/perl-Storable
+       dev-perl/String-CRC32
+       virtual/perl-Time-HiRes
+"
+BDEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+"
+src_test() {
+       ewarn "Comprehensive testing of this module needs manual configuration."
+       ewarn "For details, see:"
+       ewarn "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}"
+       echo
+       perl-module_src_test
+}