app-cdr/cdw: EAPI=7 bump
authorZamarin Arthur <arthurzam@gmail.com>
Thu, 18 Apr 2019 16:41:55 +0000 (19:41 +0300)
committerMichał Górny <mgorny@gentoo.org>
Mon, 22 Apr 2019 19:43:35 +0000 (21:43 +0200)
bump to EAPI=7
fix rebuild on SLOT for dev-libs/libcdio

Package-Manager: Portage-2.3.63, Repoman-2.3.12
Signed-off-by: Zamarin Arthur <arthurzam@gmail.com>
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-cdr/cdw/cdw-0.8.1-r1.ebuild [new file with mode: 0644]

diff --git a/app-cdr/cdw/cdw-0.8.1-r1.ebuild b/app-cdr/cdw/cdw-0.8.1-r1.ebuild
new file mode 100644 (file)
index 0000000..2e0b759
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="An ncurses based console frontend for cdrtools and dvd+rw-tools"
+HOMEPAGE="http://cdw.sourceforge.net"
+SRC_URI="mirror://sourceforge/cdw/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+       app-cdr/dvd+rw-tools
+       dev-libs/libburn
+       dev-libs/libcdio:=[-minimal]
+       sys-libs/ncurses:0=[unicode]
+       virtual/cdrtools
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS cdw.conf )
+
+src_configure() {
+       econf LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses )"
+}