sys-libs/csu: bump to EAPI=7
authorFabian Groffen <grobian@gentoo.org>
Thu, 26 Dec 2019 09:22:08 +0000 (10:22 +0100)
committerFabian Groffen <grobian@gentoo.org>
Thu, 26 Dec 2019 09:22:08 +0000 (10:22 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
sys-libs/csu/csu-85-r1.ebuild

index 28ea492c1a5d0b5de02f8ce23a0a77075cf9ccdf..8c9ad7d9a73769ff68b04a8b4c961e08b16bf230 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 
-inherit toolchain-funcs eutils
+inherit toolchain-funcs
 
 DESCRIPTION="Darwin Csu (crt1.o) - Mac OS X 10.10 version"
 HOMEPAGE="http://www.opensource.apple.com/"
@@ -33,7 +33,7 @@ src_prepare() {
                Makefile || die
 
        # only require Availability.h for arm, bugs #538602, #539964
-       epatch "${FILESDIR}"/${P}-arm-availability.patch
+       eapply "${FILESDIR}"/${P}-arm-availability.patch
 
        if [[ ${CHOST} == powerpc* ]] ; then
                # *must not* be compiled with -Os on PPC because that
@@ -44,6 +44,8 @@ src_prepare() {
                # be more than 16MB away
                sed -i -e "s, -Os , -O ,g" Makefile || die
        fi
+
+       eapply_user
 }
 
 src_compile() {