dev-libs/yajl: Drop 2.0.4-r3
authorAndreas Sturmlechner <asturm@gentoo.org>
Mon, 13 Aug 2018 20:12:25 +0000 (22:12 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Mon, 13 Aug 2018 21:40:11 +0000 (23:40 +0200)
2.1.0 has been stable for >1.5 years.

Package-Manager: Portage-2.3.46, Repoman-2.3.10

dev-libs/yajl/Manifest
dev-libs/yajl/files/yajl-2.0.4-pkgconfig_multilib.patch [deleted file]
dev-libs/yajl/files/yajl-fix_static_linking.patch [deleted file]
dev-libs/yajl/yajl-2.0.4-r3.ebuild [deleted file]

index 601a35d642a5edc412b40ac60a7e1d41b00baeb5..5dcdd7a780753d85e5cefbf92e3e1efdc9ca2cc0 100644 (file)
@@ -1,2 +1 @@
-DIST yajl-2.0.4.tar.gz 82814 BLAKE2B 4a84916c5ba6cd43aa484af559c23c05ea0b36078d1f4489d97c8c47404aa2771f9c2238f6fcbb344cb2e84f8b183b918ff2d95c50c7da8a781731614d88dbf6 SHA512 ab99fdd6b7e6f7add5530fff2d3ac6171ed3698267016d6cd23449742d36c9d848f065ba920dc2abb934488239e11e4ceda571c05fa472ab5d3f0480e9033a13
 DIST yajl-2.1.0.tar.gz 84039 BLAKE2B 53cfa60994a478050ef1ab35ecfe60cc51f166bc101ee81f42122b134cc30afd1277c3c2661f5c03dc8c8117fcfdaab8ec7c6d735a6810ea4700f1afaea60e1a SHA512 671c06081e01584d170b614dc0685f49c6d7448b673d8ed99749ce4e0ca73875af9f62df7787b919ceaecab213668ac1d2a5800b6831731ec146353552f36985
diff --git a/dev-libs/yajl/files/yajl-2.0.4-pkgconfig_multilib.patch b/dev-libs/yajl/files/yajl-2.0.4-pkgconfig_multilib.patch
deleted file mode 100644 (file)
index 4a01848..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-From 409098e97292aa1698ddff7f34dd8099db41a550 Mon Sep 17 00:00:00 2001
-From: ksergey <inndie@gmail.com>
-Date: Tue, 28 Jan 2014 00:35:36 -0500
-Subject: [PATCH] fixed pkgconfig file path
-
----
- src/CMakeLists.txt | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index e36b736..27b7c7d 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -30,7 +30,7 @@ ADD_DEFINITIONS(-DYAJL_BUILD)
- # set up some paths
- SET (libDir ${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/lib)
- SET (incDir ${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/include/yajl)
--SET (shareDir ${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/share/pkgconfig)
-+SET (pkgConfigDir ${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/lib/pkgconfig)
- # set the output path for libraries
- SET(LIBRARY_OUTPUT_PATH ${libDir})
-@@ -61,7 +61,7 @@ FILE(MAKE_DIRECTORY ${incDir})
- # generate build-time source
- SET(dollar $)
- CONFIGURE_FILE(api/yajl_version.h.cmake ${incDir}/yajl_version.h)
--CONFIGURE_FILE(yajl.pc.cmake ${shareDir}/yajl.pc)
-+CONFIGURE_FILE(yajl.pc.cmake ${pkgConfigDir}/yajl.pc)
- # copy public headers to output directory
- FOREACH (header ${PUB_HDRS})
-@@ -82,5 +82,5 @@ IF(NOT WIN32)
-   INSTALL(TARGETS yajl_s ARCHIVE DESTINATION lib${LIB_SUFFIX})
-   INSTALL(FILES ${PUB_HDRS} DESTINATION include/yajl)
-   INSTALL(FILES ${incDir}/yajl_version.h DESTINATION include/yajl)
--  INSTALL(FILES ${shareDir}/yajl.pc DESTINATION share/pkgconfig)
-+  INSTALL(FILES ${pkgConfigDir}/yajl.pc DESTINATION lib${LIB_SUFFIX}/pkgconfig)
- ENDIF()
--- 
-1.8.5.5
diff --git a/dev-libs/yajl/files/yajl-fix_static_linking.patch b/dev-libs/yajl/files/yajl-fix_static_linking.patch
deleted file mode 100644 (file)
index 56bf0e7..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -urN lloyd-yajl-f4baae0.old//reformatter/CMakeLists.txt lloyd-yajl-f4baae0//reformatter/CMakeLists.txt
---- lloyd-yajl-f4baae0.old//reformatter/CMakeLists.txt 2010-07-22 00:12:15.000000000 +0200
-+++ lloyd-yajl-f4baae0//reformatter/CMakeLists.txt     2011-02-11 19:28:40.006756997 +0100
-@@ -42,7 +42,7 @@
- ADD_EXECUTABLE(json_reformat ${SRCS})
--TARGET_LINK_LIBRARIES(json_reformat yajl_s)
-+TARGET_LINK_LIBRARIES(json_reformat yajl)
- # copy the binary into the output directory
- GET_TARGET_PROPERTY(binPath json_reformat LOCATION)
-diff -urN lloyd-yajl-f4baae0.old//verify/CMakeLists.txt lloyd-yajl-f4baae0//verify/CMakeLists.txt
---- lloyd-yajl-f4baae0.old//verify/CMakeLists.txt      2010-07-22 00:12:15.000000000 +0200
-+++ lloyd-yajl-f4baae0//verify/CMakeLists.txt  2011-02-11 19:28:58.296756998 +0100
-@@ -42,7 +42,7 @@
- ADD_EXECUTABLE(json_verify ${SRCS})
--TARGET_LINK_LIBRARIES(json_verify yajl_s)
-+TARGET_LINK_LIBRARIES(json_verify yajl)
- # copy in the binary
- GET_TARGET_PROPERTY(binPath json_verify LOCATION)
diff --git a/dev-libs/yajl/yajl-2.0.4-r3.ebuild b/dev-libs/yajl/yajl-2.0.4-r3.ebuild
deleted file mode 100644 (file)
index b0670a2..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils cmake-multilib vcs-snapshot
-
-DESCRIPTION="Small event-driven (SAX-style) JSON parser"
-HOMEPAGE="https://lloyd.github.com/yajl/"
-SRC_URI="https://github.com/lloyd/yajl/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="static-libs"
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-fix_static_linking.patch
-       "${FILESDIR}"/${P}-pkgconfig_multilib.patch
-)
-
-src_prepare() {
-       cmake-utils_src_prepare
-
-       multilib_copy_sources
-}
-
-src_test() {
-       run_test() {
-               cd "${BUILD_DIR}"/test
-               ./run_tests.sh ./yajl_test || die
-       }
-       multilib_parallel_foreach_abi run_test
-}
-
-src_install() {
-       cmake-multilib_src_install
-
-       use static-libs || \
-               find "${D}" -name libyajl_s.a -delete
-}