dev-python/uvloop: new ebuild, initial vn. 0.4.20
authorElvis Pranskevichus <elvis@magic.io>
Wed, 11 May 2016 17:06:43 +0000 (13:06 -0400)
committerIan Delaney <idella4@gentoo.org>
Fri, 13 May 2016 17:25:39 +0000 (01:25 +0800)
uvloop is a fast, drop-in replacement of the built-in asyncio
event loop. uvloop is implemented in Cython and uses libuv under
the hood.

http://github.com/MagicStack/uvloop

Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=582768
Package-Manager: portage-2.2.28
Closes: https://github.com/gentoo/gentoo/pull/1455

Signed-off-by: Ian Delaney <idella4@gentoo.org>
dev-python/uvloop/Manifest [new file with mode: 0644]
dev-python/uvloop/metadata.xml [new file with mode: 0644]
dev-python/uvloop/uvloop-0.4.20.ebuild [new file with mode: 0644]

diff --git a/dev-python/uvloop/Manifest b/dev-python/uvloop/Manifest
new file mode 100644 (file)
index 0000000..32b7369
--- /dev/null
@@ -0,0 +1 @@
+DIST uvloop-0.4.20.tar.gz 1781445 SHA256 b39afbc242eafff7471337468b28c4164f55d130f8194e0fb4a8b2eb71cb1298 SHA512 c7f540da9d29340fb0cc0e589143fabc12d4c185d4e7eff889e3434478f445e98c703fd9024af66b6b121bce3c860be2b4da497a6492a43df5891e86b6007d7e WHIRLPOOL 1d50e45cf92fca4b983222038e6524359e7160d0ac87b89265dd298d0fa9f33527c5a839752e6cc0a2d34c6eb27f0919474085616885c779b876a8638a0c5ba1
diff --git a/dev-python/uvloop/metadata.xml b/dev-python/uvloop/metadata.xml
new file mode 100644 (file)
index 0000000..d7bbdfb
--- /dev/null
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>elvis@magic.io</email>
+               <name>Elvis Pranskevichus</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <longdescription>uvloop is a fast, drop-in replacement of the built-in asyncio event loop. uvloop is implemented in Cython and uses libuv under the hood.</longdescription>
+       <upstream>
+      <remote-id type="pypi">uvloop</remote-id>
+      <remote-id type="github">MagicStack/uvloop</remote-id>
+    </upstream>
+</pkgmetadata>
diff --git a/dev-python/uvloop/uvloop-0.4.20.ebuild b/dev-python/uvloop/uvloop-0.4.20.ebuild
new file mode 100644 (file)
index 0000000..6a22761
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_5 )
+inherit distutils-r1
+
+DESCRIPTION="Ultra-fast implementation of asyncio event loop on top of libuv."
+HOMEPAGE="https://github.com/magicstack/uvloop"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc examples test"
+
+CDEPEND=">=dev-libs/libuv-1.8.0:="
+DEPEND="
+       ${CDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? (
+               >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+               >=dev-python/cython-0.23.4[${PYTHON_USEDEP}]
+               dev-python/sphinx[${PYTHON_USEDEP}]
+       )
+"
+
+RDEPEND="${CDEPEND}"
+
+src_prepare() {
+       cat <<EOF >> setup.cfg
+[build_ext]
+use-system-libuv=1
+EOF
+       distutils-r1_src_prepare
+}
+
+python_compile_all() {
+       use doc && emake docs
+}
+
+python_test() {
+       esetup.py test
+}
+
+python_install_all() {
+       if use examples; then
+               insinto "/usr/share/doc/${PF}"
+               docompress -x "/usr/share/doc/${PF}/examples"
+               doins -r examples
+       fi
+
+       use doc && local HTML_DOCS=( docs/_build/html/. )
+       distutils-r1_python_install_all
+}