new upstream release.
authorAkinori Hattori <hattya@gentoo.org>
Fri, 10 Nov 2006 10:02:06 +0000 (10:02 +0000)
committerAkinori Hattori <hattya@gentoo.org>
Fri, 10 Nov 2006 10:02:06 +0000 (10:02 +0000)
Package-Manager: portage-2.1.1-r1

app-i18n/anthy-ss/ChangeLog
app-i18n/anthy-ss/anthy-ss-8307.ebuild [new file with mode: 0644]
app-i18n/anthy-ss/files/digest-anthy-ss-8307 [new file with mode: 0644]

index b85a5774af77da94967f19c74b17976c02314a94..f76de3938d5ec3ee6f1a8f391bdd3144bf8c3de9 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for app-i18n/anthy-ss
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.90 2006/09/30 14:59:04 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.91 2006/11/10 10:02:06 hattya Exp $
+
+*anthy-ss-8307 (10 Nov 2006)
+
+  10 Nov 2006; Akinori Hattori <hattya@gentoo.org> -anthy-ss-8130.ebuild,
+  +anthy-ss-8307.ebuild:
+  new upstream release.
 
 *anthy-ss-8130 (30 Sep 2006)
 
diff --git a/app-i18n/anthy-ss/anthy-ss-8307.ebuild b/app-i18n/anthy-ss/anthy-ss-8307.ebuild
new file mode 100644 (file)
index 0000000..fd13da8
--- /dev/null
@@ -0,0 +1,74 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/anthy-ss-8307.ebuild,v 1.1 2006/11/10 10:02:06 hattya Exp $
+
+inherit elisp-common eutils
+
+IUSE="emacs ucs4"
+
+MY_P=${P/-ss/}
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/22628/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+SLOT="0"
+S=${WORKDIR}/${MY_P}
+
+DEPEND="!app-i18n/anthy
+       emacs? ( virtual/emacs )"
+
+src_unpack() {
+
+       unpack ${A}
+       cd "${S}"
+
+       local cannadicdir=/var/lib/canna/dic/canna
+
+       if has_version 'app-dicts/canna-2ch'; then
+               einfo "Adding nichan.ctd to anthy.dic."
+               sed -i /placename/a"read ${cannadicdir}/nichan.ctd" \
+                       mkworddic/dict.args.in
+       fi
+
+}
+
+src_compile() {
+
+       local myconf
+
+       use emacs || myconf="EMACS=no"
+       use ucs4 && myconf="${myconf} --enable-ucs4"
+
+       econf ${myconf} || die
+       emake || die
+
+}
+
+src_install() {
+
+       emake DESTDIR="${D}" install || die
+
+       use emacs && elisp-site-file-install "${FILESDIR}"/50anthy-gentoo.el
+
+       dodoc AUTHORS DIARY NEWS README ChangeLog
+
+       docinto doc
+       rm doc/Makefile*
+       dodoc doc/*
+
+}
+
+pkg_postinst() {
+
+       use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+       has_version virtual/emacs && elisp-site-regen
+
+}
diff --git a/app-i18n/anthy-ss/files/digest-anthy-ss-8307 b/app-i18n/anthy-ss/files/digest-anthy-ss-8307
new file mode 100644 (file)
index 0000000..6929044
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 b1e448ecadf136d551e720f2adcbfd84 anthy-8307.tar.gz 3532731
+RMD160 f05c0cea014136f028fa7f3dbded31b8a50238f7 anthy-8307.tar.gz 3532731
+SHA256 4efd30c52c10bc24d94f2848c04d3f9de6e62552f906b877c19074a569018114 anthy-8307.tar.gz 3532731