dev-python/setuptools_scm_git_archive: python2 support not needed, fix tests
authorPacho Ramos <pacho@gentoo.org>
Thu, 30 Apr 2020 17:18:07 +0000 (19:18 +0200)
committerPacho Ramos <pacho@gentoo.org>
Thu, 30 Apr 2020 17:18:07 +0000 (19:18 +0200)
All reverse deps are ported to python3, fix tests

Thanks-to: Agostino Sarubbo
Closes: https://bugs.gentoo.org/720064
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild

index 0747a089249098b4ee9585afa172f75a1861cc6a..94d423503545d2dc0203bf3309140041e2ac998d 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
 inherit distutils-r1
 
 DESCRIPTION="A setuptools_scm plugin for git archives"
@@ -21,11 +21,13 @@ DEPEND="
 "
 RDEPEND="${DEPEND}"
 
+distutils_enable_tests pytest
+
 src_prepare() {
        export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
        distutils-r1_src_prepare
 }
 
 python_test() {
-       esetup.py test
+       pytest tests.py || die
 }