net-print/cups-filters: Bump to version 1.22.5
authorLars Wendler <polynomial-c@gentoo.org>
Sun, 7 Apr 2019 23:51:19 +0000 (01:51 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Sun, 7 Apr 2019 23:52:21 +0000 (01:52 +0200)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-print/cups-filters/Manifest
net-print/cups-filters/cups-filters-1.22.5.ebuild [new file with mode: 0644]

index 2ddebc81d5d903bdba219f399ad05c32ce252f22..134e489c5d7a2ee70732f3cfc819396db866aed1 100644 (file)
@@ -1,3 +1,4 @@
 DIST cups-filters-1.21.6.tar.xz 1474944 BLAKE2B a4c3418accb9d2bf46a366ec6004919d2a5c2c0a02022102270da17fb81915428275aadf58f1f50f8ca022e1c09cbdbd7300492fa38c53d4a2cbc4c4b86a09e3 SHA512 804250745ac710706ff1bfa6e161c0b1a8a65a74850a76a311b7614694a7e5d07f01dfd15f277ad79ed7fe1e84ea680bab1643e0b82cefa3e26603fa2eea935a
 DIST cups-filters-1.22.2.tar.xz 1476812 BLAKE2B fa64a0cf3a0c62053914a603366cf6982ce703b44c40dcd1c4410e180f22cd929cc4f1fee4e00945fa9e73dfbc5bae8b664527c32060be42050882a861412ae0 SHA512 da9873f01baf9436c00009348ea8033df1c9e44c97839e16841241510fbb1f3d93fc57ee593d1286bdfeab0a89c15b0f7d74c932bd48f3a623c7c10d200bbd6a
 DIST cups-filters-1.22.3.tar.xz 1476460 BLAKE2B 3db5a5b2f048a4e3929f7e4080c5d50b5b68bc6456df4d9360395edcb4954701da960d63dd8e885bcd8b7d93bb31c3b0d6511f69893b3e4e8df445b6fa1f13b8 SHA512 8f91f7261babf2e4633590e1f69f3c85162596bba9a709d301f774eb65f83e7c025493cabbbc5d91beca32f5122e2d4e1efa9947e2d95b9a622913a79940a534
+DIST cups-filters-1.22.5.tar.xz 1476792 BLAKE2B 77efec3c6c8287b22ab96185e609e8da30ebd20d9c944ba0a3057bd1469e12d30cf6775988500e4f410410160d8766df1d6432e81116cbf926e7c75f49cddb5d SHA512 ed33e6d6f090c00f0f0d1d012d3b394bfaa1f81feeb5b0b7ead1dffa2399f0165ce916a99c3bf28aca7f279bffba5b6575feff700130cabfcd46eb4c904d5c59
diff --git a/net-print/cups-filters/cups-filters-1.22.5.ebuild b/net-print/cups-filters/cups-filters-1.22.5.ebuild
new file mode 100644 (file)
index 0000000..9549f96
--- /dev/null
@@ -0,0 +1,135 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit perl-module systemd flag-o-matic
+
+if [[ "${PV}" == "9999" ]] ; then
+       inherit autotools git-r3
+       EGIT_REPO_URI="https://github.com/OpenPrinting/cups-filters.git"
+else
+       SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~m68k-mint"
+fi
+DESCRIPTION="Cups filters"
+HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/cups-filters"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="dbus +foomatic ipp_autosetup jpeg ldap pclm pdf perl png +postscript static-libs test tiff zeroconf"
+
+RDEPEND="
+       >=app-text/poppler-0.32:=[cxx,jpeg?,lcms,tiff?,utils]
+       >=app-text/qpdf-8.3.0:=
+       dev-libs/glib:2
+       media-libs/fontconfig
+       media-libs/freetype:2
+       media-libs/lcms:2
+       >=net-print/cups-1.7.3
+       !<=net-print/cups-1.5.9999
+       sys-devel/bc
+       sys-libs/zlib
+       dbus? ( sys-apps/dbus )
+       foomatic? ( !net-print/foomatic-filters )
+       jpeg? ( virtual/jpeg:0 )
+       ldap? ( net-nds/openldap )
+       pdf? ( app-text/mupdf )
+       perl? ( dev-lang/perl:= )
+       png? ( media-libs/libpng:0= )
+       postscript? ( >=app-text/ghostscript-gpl-9.09[cups] )
+       tiff? ( media-libs/tiff:0 )
+       zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}
+       dev-util/gdbus-codegen
+       test? ( media-fonts/dejavu )
+"
+
+src_prepare() {
+       default
+       [[ "${PV}" == "9999" ]] && eautoreconf
+
+       # Bug #626800
+       append-cxxflags -std=c++11
+}
+
+src_configure() {
+       local myeconfargs=(
+               --enable-imagefilters
+               --localstatedir="${EPREFIX}"/var
+               --with-browseremoteprotocols=DNSSD,CUPS
+               --with-cups-rundir="${EPREFIX}"/run/cups
+               --with-fontdir="fonts/conf.avail"
+               --with-pdftops=pdftops
+               --with-rcdir=no
+               --without-php
+               $(use_enable dbus)
+               $(use_enable foomatic)
+               $(use_enable ipp_autosetup auto-setup-driverless)
+               $(use_enable ldap)
+               $(use_enable pclm)
+               $(use_enable pdf mutool)
+               $(use_enable postscript ghostscript)
+               $(use_enable postscript ijs)
+               $(use_enable static-libs static)
+               $(use_enable zeroconf avahi)
+               $(use_with jpeg)
+               $(use_with png)
+               $(use_with tiff)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+       default
+
+       if use perl; then
+               pushd "${S}/scripting/perl" > /dev/null
+               perl-module_src_configure
+               perl-module_src_compile
+               popd > /dev/null
+       fi
+}
+
+src_install() {
+       default
+
+       if use perl; then
+               pushd "${S}/scripting/perl" > /dev/null
+               perl-module_src_install
+               perl_delete_localpod
+               popd > /dev/null
+       fi
+
+       if use postscript; then
+               # workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
+               dosym gstoraster /usr/libexec/cups/filter/pstoraster
+               dosym gstopxl /usr/libexec/cups/filter/pstopxl
+       fi
+
+       find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+
+       cp "${FILESDIR}"/cups-browsed.init.d-r1 "${T}"/cups-browsed || die
+
+       if ! use zeroconf ; then
+               sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
+               sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
+       fi
+
+       doinitd "${T}"/cups-browsed
+       systemd_dounit "${S}/utils/cups-browsed.service"
+}
+
+src_test() {
+       emake check
+}
+
+pkg_postinst() {
+       if ! use foomatic ; then
+               ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
+               ewarn "necessary. net-print/foomatic-filters as replacement is deprecated and unmaintained."
+       fi
+}