net-libs/liboping: drop old
authorThomas Deutschmann <whissi@gentoo.org>
Tue, 18 Jun 2019 12:51:59 +0000 (14:51 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Tue, 18 Jun 2019 12:55:35 +0000 (14:55 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
net-libs/liboping/liboping-1.10.0-r1.ebuild [deleted file]

diff --git a/net-libs/liboping/liboping-1.10.0-r1.ebuild b/net-libs/liboping/liboping-1.10.0-r1.ebuild
deleted file mode 100644 (file)
index 50dc00c..0000000
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit autotools fcaps perl-module
-
-DESCRIPTION="Protocol independent ANSI-C ping library and command line utility"
-HOMEPAGE="https://noping.cc/"
-SRC_URI="https://noping.cc/files/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1 GPL-2"
-SLOT="0/0.3"
-KEYWORDS="alpha amd64 arm x86"
-IUSE="+filecaps ncurses perl"
-
-DEPEND="ncurses? ( sys-libs/ncurses:0= )"
-RDEPEND=${DEPEND}
-
-PATCHES=(
-       "${FILESDIR}/${PN}-1.6.2-nouidmagic.patch"
-       "${FILESDIR}"/${P}-gcc8-fix.patch
-)
-
-src_prepare() {
-       default
-
-       eautoreconf
-}
-
-src_configure() {
-       econf \
-               $(use_with perl perl-bindings INSTALLDIRS=vendor) \
-               $(use_with ncurses)
-}
-
-src_test() {
-       if use perl; then
-               pushd bindings/perl >/dev/null || die
-               perl-module_src_test
-               popd >/dev/null || die
-       fi
-}
-
-src_install() {
-       default
-
-       find "${ED}"usr/lib* -name '*.la' -o -name '*.a' -delete || die
-}
-
-pkg_postinst() {
-       if use filecaps; then
-               local _caps_str="CAP_NET_RAW"
-               _files=( "${EROOT%/}/usr/bin/oping")
-
-               if use ncurses; then
-                       _files+=( "${EROOT%/}/usr/bin/noping")
-               fi
-
-               fcaps "${_caps_str}" "${_files[@]}"
-
-               elog "Capabilities for"
-               elog ""
-
-               local _file=
-               for _file in "${_files[@]}"; do
-                       elog "  ${_file}"
-               done
-
-               elog ""
-               elog "set to ${_caps_str}+EP due to set 'filecaps' USE flag."
-               elog
-       fi
-}