dev-python/jaraco-itertools: Remove old
authorMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 12:55:45 +0000 (13:55 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 12:59:57 +0000 (13:59 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/jaraco-itertools/Manifest
dev-python/jaraco-itertools/jaraco-itertools-2.3-r1.ebuild [deleted file]

index a2fb08a1f6e7cd49190e4de879bb692e2091f66e..019029469e8f0d5a5a890b90bbe439dd2384a620 100644 (file)
@@ -1,3 +1,2 @@
-DIST jaraco.itertools-2.3.tar.gz 12857 BLAKE2B 714b123965af3ff593205aab373f3097709729377cd867ca2a7ccbb7795b1818f47b0b316d4c927c9aec4eb66fe1da63b44c1d60db310dd97b5444b01f7db04d SHA512 070a442531fd079fefcb61bbbdb0cc98bc88cbc5f23f6cb40ee1fafbc9a259c69e0a373e949ab54d22836f54b0de41e1b09d10692f92d18030825ca09345be48
 DIST jaraco.itertools-4.4.2.tar.gz 19431 BLAKE2B d3493380f9522d436d4d8dbcdf484e7fd4fa223e96fabde0d7f3803c395e56d0bd28f49b9a6bfec0b680fdff7f5d145c85530036157f7976ffa82fc4851e3105 SHA512 74db7a3c7595c7deaf2a0c9ba68e9b02d02ccbc6c65142de34a5339aac679c2d71f05b27e27632d265de4f78997e11d7dc43178bd0d64f3010e1568a5085812c
 DIST jaraco.itertools-5.0.0.tar.gz 19517 BLAKE2B b38bbb75daa53ce9390a51099b3ebad16696924c26c6674a7c5b9ae5e219db6560d1bae24b4c491d6e424b7fecea66dac2eab673d0cfa91fbdb3a4246b852944 SHA512 38ae2cbdd436b277e3d3c252fadeb5239e2d32b2291686b2a3dbaca69328392eb1db4318b2144954b17302e5b15b94ad89f1ea8a1b2e354deec7d4516bd7ec85
diff --git a/dev-python/jaraco-itertools/jaraco-itertools-2.3-r1.ebuild b/dev-python/jaraco-itertools/jaraco-itertools-2.3-r1.ebuild
deleted file mode 100644 (file)
index a521773..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# Tests fail with PyPy and PyPy 3
-PYTHON_COMPAT=( python{2_7,3_6} )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Tools for working with iterables. Complements itertools and more_itertools"
-HOMEPAGE="https://github.com/jaraco/jaraco.itertools"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       <dev-python/namespace-jaraco-2[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-       dev-python/inflect[${PYTHON_USEDEP}]
-       >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
-"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
-       doc? (
-               dev-python/sphinx[${PYTHON_USEDEP}]
-               dev-python/rst-linker[${PYTHON_USEDEP}]
-       )
-       test? (
-               ${RDEPEND}
-               >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
-       )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_compile_all() {
-       if use doc; then
-               sphinx-build docs docs/_build/html || die
-               HTML_DOCS=( docs/_build/html/. )
-       fi
-}
-
-python_test() {
-       # Override pytest options to skip flake8
-       PYTHONPATH=. py.test --override-ini="addopts=--doctest-modules" \
-               || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-       find "${ED}" -name '*.pth' -delete || die
-}