dev-util/fix-la-relink-command: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Tue, 18 Feb 2020 19:11:13 +0000 (20:11 +0100)
committerDavid Seifert <soap@gentoo.org>
Tue, 18 Feb 2020 19:11:13 +0000 (20:11 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-util/fix-la-relink-command/fix-la-relink-command-0.1.1.ebuild

index b50cca94ecf4de1b07242cdf296188d1700dae91..8e221804e4104a76e6bb88df183ffe04768b3c5f 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="4"
+EAPI=7
 
 DESCRIPTION="Helps prevent .la files from relinking to libraries outside a build tree"
 HOMEPAGE="https://dev.gentoo.org/~tetromino/distfiles/fix-la-relink-command"
@@ -10,15 +10,14 @@ SRC_URI="https://dev.gentoo.org/~tetromino/distfiles/${PN}/${P}.tar.xz"
 LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
 SLOT="0"
 KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
 
-RDEPEND="dev-lang/perl
+RDEPEND="
+       dev-lang/perl
        virtual/perl-Getopt-Long"
-DEPEND="${RDEPEND}
-       app-arch/xz-utils"
+BDEPEND="app-arch/xz-utils"
 
 src_install() {
        dobin ${PN}
        doman ${PN}.1
-       dodoc NEWS
+       einstalldocs
 }