dev-vcs/git-remote-hg: bump version to 1.0.1
authorNikos Chantziaras <realnc@gmail.com>
Thu, 2 May 2019 06:30:03 +0000 (09:30 +0300)
committerMichał Górny <mgorny@gentoo.org>
Fri, 7 Jun 2019 13:14:13 +0000 (15:14 +0200)
setup.py was fixed upstream. Patch no longer needed.

Closes: https://bugs.gentoo.org/684912
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Nikos Chantziaras <realnc@gmail.com>
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-vcs/git-remote-hg/Manifest
dev-vcs/git-remote-hg/git-remote-hg-1.0.1.ebuild [new file with mode: 0644]

index 16b5236e9a5043b5ef2feaeb110e5f2e5c2dc839..ac7f4a97ddf8d14035a82eed786e9928e50d3aaa 100644 (file)
@@ -1 +1,2 @@
 DIST git-remote-hg-1.0.0.tar.gz 57611 BLAKE2B f46ca860bd7c46985ef53d5adfb949290208e351425a31fbfd33e6cf632c40b043397d398a5c378c653ab2b303d427c4b5bf29250fb51631f87cb2dbb0b541b5 SHA512 344349b8c64db5ad629176c664713773b4e8fe5ddf6bd13e7f3cac421f82eeb93fdd8aa59a2baab4b36b533cd6721adf8d31c69d4cc761e43c093c4d531c1a7d
+DIST git-remote-hg-1.0.1.tar.gz 57856 BLAKE2B 635073fbd0d9fe0ebbc2e9b5e49298bdb9f6b02f964219271a4bd930746e892e58fabde2afa94e998e4bd4aede91d9ac80291eef1bd3eb16cf82f6691514259b SHA512 b665cb6dc0564dc7f2cacade9000378f895b77a3186e091b841e58ddef37834e3cc87e81a76ab713997c6f837a768eff91d6b8a156c6277da0e34a2f156a5290
diff --git a/dev-vcs/git-remote-hg/git-remote-hg-1.0.1.ebuild b/dev-vcs/git-remote-hg/git-remote-hg-1.0.1.ebuild
new file mode 100644 (file)
index 0000000..6351dae
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Semi-official Mercurial bridge from Git project"
+HOMEPAGE="https://github.com/mnauw/git-remote-hg"
+SRC_URI="https://github.com/mnauw/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+       app-text/asciidoc
+"
+RDEPEND="
+       dev-vcs/git
+       dev-vcs/mercurial
+"
+
+# Some tests fail.
+RESTRICT="test"
+
+src_compile() {
+       distutils-r1_src_compile
+       emake doc
+}
+
+src_install() {
+       distutils-r1_src_install
+       emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install-doc
+}
+
+src_test() {
+       default
+}