dev-util/conf2struct: Respect CFLAGS and CC
authorCraig Andrews <candrews@gentoo.org>
Fri, 19 Jul 2019 15:46:08 +0000 (11:46 -0400)
committerCraig Andrews <candrews@gentoo.org>
Fri, 19 Jul 2019 15:47:10 +0000 (11:47 -0400)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Craig Andrews <candrews@gentoo.org>
dev-util/conf2struct/conf2struct-0_pre0-r1.ebuild [new file with mode: 0644]
dev-util/conf2struct/conf2struct-9999.ebuild

diff --git a/dev-util/conf2struct/conf2struct-0_pre0-r1.ebuild b/dev-util/conf2struct/conf2struct-0_pre0-r1.ebuild
new file mode 100644 (file)
index 0000000..b31468b
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic systemd toolchain-funcs
+
+DESCRIPTION="Create C parsers for libconfig and command-line"
+HOMEPAGE="https://github.com/yrutschle/conf2struct/"
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/yrutschle/conf2struct.git"
+       inherit git-r3
+else
+       KEYWORDS="~amd64"
+       GIT_COMMIT="10ea3356b65e712fb000f4d37f00e1dc09c1e722"
+       SRC_URI="https://github.com/yrutschle/conf2struct/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}/${PN}-${GIT_COMMIT}"
+fi
+
+PATCHES=(
+       "${FILESDIR}/${P}-install-and-uninstall.patch"
+       "${FILESDIR}/${P}-cc-and-cflags.patch"
+       "${FILESDIR}/${P}-destdir.patch"
+       "${FILESDIR}/${P}-install-not-run-all.patch"
+       "${FILESDIR}/${P}-dest-exists.patch"
+)
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/libconfig
+       dev-perl/Conf-Libconfig"
+DEPEND="${RDEPEND}"
+
+src_compile(){
+       # -j1 due to parallel make issue reported upstream at: https://github.com/yrutschle/conf2struct/issues/10
+       emake -j1 CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install(){
+       emake DESTDIR="${D}" prefix="${EPREFIX%/}/usr" install
+}
index f20edc27e4dbeb9de96b940d2d4eeaf14d4a5bed..b853d93f1b86a2a60ac52c2d52fca6b3bfcb3dc5 100644 (file)
@@ -23,6 +23,10 @@ RDEPEND="dev-libs/libconfig
        dev-perl/Conf-Libconfig"
 DEPEND="${RDEPEND}"
 
+src_compile(){
+       emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
 src_install(){
        emake DESTDIR="${D}" prefix="${EPREFIX%/}/usr" install
 }