dev-python/pyopenssl: Run tests with TZ=UTC
authorPPed72 <paolo.pedroni@iol.it>
Mon, 27 Nov 2017 17:41:59 +0000 (18:41 +0100)
committerMike Gilbert <floppym@gentoo.org>
Mon, 27 Nov 2017 17:52:22 +0000 (12:52 -0500)
Closes: https://bugs.gentoo.org/627530

dev-python/pyopenssl/pyopenssl-17.2.0.ebuild
dev-python/pyopenssl/pyopenssl-17.3.0.ebuild
dev-python/pyopenssl/pyopenssl-17.4.0.ebuild

index e417175b253bb33144ea19a17bbd2ac5089bc326..16630e5d7b901ebb2f3bae98578dc3d6366e8935 100644 (file)
@@ -51,8 +51,7 @@ python_compile_all() {
 }
 
 python_test() {
-       # FIXME: for some reason, no-ops on PyPy
-       py.test -v || die "Testing failed with ${EPYTHON}"
+       TZ=UTC py.test -v || die "Testing failed with ${EPYTHON}" # Fixes bug #627530
 }
 
 python_install_all() {
index d873a6b97ce342e563cb1774a20fdf9165d7f359..bd636d9c7a75d7409a2236cf705ca102cbd4c4a5 100644 (file)
@@ -51,8 +51,7 @@ python_compile_all() {
 }
 
 python_test() {
-       # FIXME: for some reason, no-ops on PyPy
-       py.test -v || die "Testing failed with ${EPYTHON}"
+       TZ=UTC py.test -v || die "Testing failed with ${EPYTHON}" # Fixes bug #627530
 }
 
 python_install_all() {
index d873a6b97ce342e563cb1774a20fdf9165d7f359..bd636d9c7a75d7409a2236cf705ca102cbd4c4a5 100644 (file)
@@ -51,8 +51,7 @@ python_compile_all() {
 }
 
 python_test() {
-       # FIXME: for some reason, no-ops on PyPy
-       py.test -v || die "Testing failed with ${EPYTHON}"
+       TZ=UTC py.test -v || die "Testing failed with ${EPYTHON}" # Fixes bug #627530
 }
 
 python_install_all() {