Push out r5 release for selinux-base-policy (and depending packages). Main introducti...
authorSven Vermeulen <swift@gentoo.org>
Sun, 23 Oct 2011 11:00:19 +0000 (11:00 +0000)
committerSven Vermeulen <swift@gentoo.org>
Sun, 23 Oct 2011 11:00:19 +0000 (11:00 +0000)
Package-Manager: portage-2.1.10.11/cvs/Linux x86_64

12 files changed:
sec-policy/selinux-asterisk/ChangeLog
sec-policy/selinux-asterisk/selinux-asterisk-2.20110726-r2.ebuild [new file with mode: 0644]
sec-policy/selinux-base-policy/ChangeLog
sec-policy/selinux-base-policy/selinux-base-policy-2.20110726-r5.ebuild [new file with mode: 0644]
sec-policy/selinux-dbus/ChangeLog
sec-policy/selinux-dbus/selinux-dbus-2.20110726-r1.ebuild [new file with mode: 0644]
sec-policy/selinux-mozilla/ChangeLog
sec-policy/selinux-mozilla/selinux-mozilla-2.20110726-r3.ebuild [new file with mode: 0644]
sec-policy/selinux-pan/ChangeLog
sec-policy/selinux-pan/selinux-pan-2.20110726-r2.ebuild [new file with mode: 0644]
sec-policy/selinux-skype/ChangeLog
sec-policy/selinux-skype/selinux-skype-2.20110726-r2.ebuild [new file with mode: 0644]

index c3b4501e7696f740fba0ca5e5b1242c10d71ef7e..f6b63669610d631cbcb2c2d6903ef65c3c018c35 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for sec-policy/selinux-asterisk
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-asterisk/ChangeLog,v 1.20 2011/08/28 21:12:57 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-asterisk/ChangeLog,v 1.21 2011/10/23 11:00:19 swift Exp $
+
+*selinux-asterisk-2.20110726-r2 (23 Oct 2011)
+
+  23 Oct 2011; <swift@gentoo.org> +selinux-asterisk-2.20110726-r2.ebuild:
+  Fix asterisk -r usage
 
 *selinux-asterisk-2.20110726-r1 (28 Aug 2011)
 
diff --git a/sec-policy/selinux-asterisk/selinux-asterisk-2.20110726-r2.ebuild b/sec-policy/selinux-asterisk/selinux-asterisk-2.20110726-r2.ebuild
new file mode 100644 (file)
index 0000000..3053874
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-asterisk/selinux-asterisk-2.20110726-r2.ebuild,v 1.1 2011/10/23 11:00:19 swift Exp $
+EAPI="4"
+
+IUSE=""
+MODS="asterisk"
+BASEPOL="2.20110726-r5"
+
+inherit selinux-policy-2
+
+DESCRIPTION="SELinux policy for asterisk"
+
+KEYWORDS="~amd64 ~x86"
index 5e5ea0a570f40ce7d1f27f7d2f35fde2d9e09b84..0a5fcdf4d8528f9a3cc209a4480b8604804fa11c 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for sec-policy/selinux-base-policy
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/ChangeLog,v 1.84 2011/09/17 16:20:17 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/ChangeLog,v 1.85 2011/10/23 11:00:19 swift Exp $
+
+*selinux-base-policy-2.20110726-r5 (23 Oct 2011)
+
+  23 Oct 2011; <swift@gentoo.org> +selinux-base-policy-2.20110726-r5.ebuild:
+  Update patches with XDG support, clean up patches with upstream feedback,
+  include asterisk fix
 
 *selinux-base-policy-2.20110726-r4 (17 Sep 2011)
 
diff --git a/sec-policy/selinux-base-policy/selinux-base-policy-2.20110726-r5.ebuild b/sec-policy/selinux-base-policy/selinux-base-policy-2.20110726-r5.ebuild
new file mode 100644 (file)
index 0000000..67668e9
--- /dev/null
@@ -0,0 +1,166 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/selinux-base-policy-2.20110726-r5.ebuild,v 1.1 2011/10/23 11:00:19 swift Exp $
+
+EAPI="4"
+IUSE="+peer_perms +open_perms +ubac doc"
+
+inherit eutils
+
+DESCRIPTION="Gentoo base policy for SELinux"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/selinux/"
+SRC_URI="http://oss.tresys.com/files/refpolicy/refpolicy-${PV}.tar.bz2
+       http://dev.gentoo.org/~swift/patches/${PN}/patchbundle-${PF}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=sys-apps/policycoreutils-1.30.30
+       >=sys-fs/udev-151"
+DEPEND="${RDEPEND}
+       sys-devel/m4
+       >=sys-apps/checkpolicy-1.30.12"
+
+S=${WORKDIR}/
+
+src_prepare() {
+       # Apply the gentoo patches to the policy. These patches are only necessary
+       # for base policies, or for interface changes on modules.
+       EPATCH_MULTI_MSG="Applying SELinux policy updates ... " \
+       EPATCH_SUFFIX="patch" \
+       EPATCH_SOURCE="${WORKDIR}" \
+       EPATCH_FORCE="yes" \
+       epatch
+
+       cd "${S}/refpolicy"
+       # Fix bug 257111 - Correct the initial sid for cron-started jobs in the
+       # system_r role
+       sed -i -e 's:system_crond_t:system_cronjob_t:g' \
+               "${S}/refpolicy/config/appconfig-standard/default_contexts"
+       sed -i -e 's|system_r:cronjob_t|system_r:system_cronjob_t|g' \
+               "${S}/refpolicy/config/appconfig-mls/default_contexts"
+       sed -i -e 's|system_r:cronjob_t|system_r:system_cronjob_t|g' \
+               "${S}/refpolicy/config/appconfig-mcs/default_contexts"
+}
+
+src_configure() {
+       [ -z "${POLICY_TYPES}" ] && local POLICY_TYPES="targeted strict mls mcs"
+
+       # Update the SELinux refpolicy capabilities based on the users' USE flags.
+
+       if ! use peer_perms; then
+               sed -i -e '/network_peer_controls/d' \
+                       "${S}/refpolicy/policy/policy_capabilities"
+       fi
+
+       if ! use open_perms; then
+               sed -i -e '/open_perms/d' \
+                       "${S}/refpolicy/policy/policy_capabilities"
+       fi
+
+       if ! use ubac; then
+               sed -i -e '/^UBAC/s/y/n/' "${S}/refpolicy/build.conf" \
+                       || die "Failed to disable User Based Access Control"
+       fi
+
+       echo "DISTRO = gentoo" >> "${S}/refpolicy/build.conf"
+
+       # Setup the policies based on the types delivered by the end user.
+       # These types can be "targeted", "strict", "mcs" and "mls".
+       for i in ${POLICY_TYPES}; do
+               cp -a "${S}/refpolicy" "${S}/${i}"
+
+               cd "${S}/${i}";
+               make conf || die "Make conf in ${i} failed"
+
+               # Define what we see as "base" and what we want to remain modular.
+               cp "${FILESDIR}/modules.conf" \
+                       "${S}/${i}/policy/modules.conf" \
+                       || die "failed to set up modules.conf"
+               # In case of "targeted", we add the "unconfined" to the base policy
+               if [[ "${i}" == "targeted" ]];
+               then
+                       echo "unconfined = base" >> "${S}/${i}/policy/modules.conf"
+               fi
+               # Add xdg support
+               echo "xdg = base" >> "${S}/${i}/policy/modules.conf"
+
+               sed -i -e '/^QUIET/s/n/y/' -e "/^NAME/s/refpolicy/$i/" \
+                       "${S}/${i}/build.conf" || die "build.conf setup failed."
+
+               if [[ "${i}" == "mls" ]] || [[ "${i}" == "mcs" ]];
+               then
+                       # MCS/MLS require additional settings
+                       sed -i -e "/^TYPE/s/standard/${i}/" "${S}/${i}/build.conf" \
+                               || die "failed to set type to mls"
+               fi
+
+               if [ "${i}" == "targeted" ]; then
+                       sed -i -e '/root/d' -e 's/user_u/unconfined_u/' \
+                       "${S}/${i}/config/appconfig-standard/seusers" \
+                       || die "targeted seusers setup failed."
+               fi
+       done
+}
+
+src_compile() {
+       [ -z "${POLICY_TYPES}" ] && local POLICY_TYPES="targeted strict mls mcs"
+
+       for i in ${POLICY_TYPES}; do
+               cd "${S}/${i}"
+               make base || die "${i} compile failed"
+               if use doc; then
+                       make html || die
+               fi
+       done
+}
+
+src_install() {
+       [ -z "${POLICY_TYPES}" ] && local POLICY_TYPES="targeted strict mls mcs"
+
+       for i in ${POLICY_TYPES}; do
+               cd "${S}/${i}"
+
+               make DESTDIR="${D}" install \
+                       || die "${i} install failed."
+
+               make DESTDIR="${D}" install-headers \
+                       || die "${i} headers install failed."
+
+               echo "run_init_t" > "${D}/etc/selinux/${i}/contexts/run_init_type"
+
+               echo "textrel_shlib_t" >> "${D}/etc/selinux/${i}/contexts/customizable_types"
+
+               # libsemanage won't make this on its own
+               keepdir "/etc/selinux/${i}/policy"
+
+               if use doc; then
+                       dohtml doc/html/*;
+               fi
+       done
+
+       dodoc doc/Makefile.example doc/example.{te,fc,if}
+
+       insinto /etc/selinux
+       doins "${FILESDIR}/config"
+}
+
+pkg_preinst() {
+       has_version "<${CATEGORY}/${PN}-2.20101213-r13"
+       previous_less_than_r13=$?
+}
+
+pkg_postinst() {
+       [ -z "${POLICY_TYPES}" ] && local POLICY_TYPES="targeted strict mls mcs"
+
+       for i in ${POLICY_TYPES}; do
+               einfo "Inserting base module into ${i} module store."
+
+               cd "${ROOT}/usr/share/selinux/${i}"
+               semodule -s "${i}" -b base.pp || die "Could not load in new base policy"
+       done
+       elog "Updates on policies might require you to relabel files. If you, after"
+       elog "installing new SELinux policies, get 'permission denied' errors,"
+       elog "relabelling your system using 'rlpkg -a -r' might resolve the issues."
+}
index 8c726a1b6211ceb0e37ab39b79c02110a19f45a7..8fdc84573c9cdf3678e289b3c662074243a67404 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for sec-policy/selinux-dbus
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-dbus/ChangeLog,v 1.15 2011/08/28 21:13:13 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-dbus/ChangeLog,v 1.16 2011/10/23 11:00:19 swift Exp $
+
+*selinux-dbus-2.20110726-r1 (23 Oct 2011)
+
+  23 Oct 2011; <swift@gentoo.org> +selinux-dbus-2.20110726-r1.ebuild:
+  Add support for XDG type
 
 *selinux-dbus-2.20110726 (28 Aug 2011)
 
diff --git a/sec-policy/selinux-dbus/selinux-dbus-2.20110726-r1.ebuild b/sec-policy/selinux-dbus/selinux-dbus-2.20110726-r1.ebuild
new file mode 100644 (file)
index 0000000..7127a34
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-dbus/selinux-dbus-2.20110726-r1.ebuild,v 1.1 2011/10/23 11:00:19 swift Exp $
+EAPI="4"
+
+IUSE=""
+MODS="dbus"
+BASEPOL="2.20110726-r5"
+
+inherit selinux-policy-2
+
+DESCRIPTION="SELinux policy for dbus"
+
+KEYWORDS="~amd64 ~x86"
index f642340f4958c4c31889aceb7a7626781fb5904e..b01c60a631e0baadfe78730e7b97d18eecee578a 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for sec-policy/selinux-mozilla
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-mozilla/ChangeLog,v 1.8 2011/09/17 16:20:16 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-mozilla/ChangeLog,v 1.9 2011/10/23 11:00:18 swift Exp $
+
+*selinux-mozilla-2.20110726-r3 (23 Oct 2011)
+
+  23 Oct 2011; <swift@gentoo.org> +selinux-mozilla-2.20110726-r3.ebuild:
+  Add support for XDG type
 
 *selinux-mozilla-2.20110726-r2 (17 Sep 2011)
 
diff --git a/sec-policy/selinux-mozilla/selinux-mozilla-2.20110726-r3.ebuild b/sec-policy/selinux-mozilla/selinux-mozilla-2.20110726-r3.ebuild
new file mode 100644 (file)
index 0000000..51fe895
--- /dev/null
@@ -0,0 +1,13 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-mozilla/selinux-mozilla-2.20110726-r3.ebuild,v 1.1 2011/10/23 11:00:18 swift Exp $
+EAPI="4"
+
+IUSE=""
+MODS="mozilla"
+BASEPOL="2.20110726-r5"
+
+inherit selinux-policy-2
+
+DESCRIPTION="SELinux policy for mozilla"
+KEYWORDS="~amd64 ~x86"
index 2aace06e389fe2f323e3b90a2ce16caff88d123d..0fafffffb09e8212ba2a9d581102ce4fb33d4af9 100644 (file)
@@ -1,5 +1,10 @@
 
 
+*selinux-pan-2.20110726-r2 (23 Oct 2011)
+
+  23 Oct 2011; <swift@gentoo.org> +selinux-pan-2.20110726-r2.ebuild:
+  Add support for XDG
+
 *selinux-pan-2.20110726-r1 (28 Aug 2011)
 
   28 Aug 2011; <swift@gentoo.org> +selinux-pan-2.20110726-r1.ebuild:
diff --git a/sec-policy/selinux-pan/selinux-pan-2.20110726-r2.ebuild b/sec-policy/selinux-pan/selinux-pan-2.20110726-r2.ebuild
new file mode 100644 (file)
index 0000000..e3952cf
--- /dev/null
@@ -0,0 +1,13 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-pan/selinux-pan-2.20110726-r2.ebuild,v 1.1 2011/10/23 11:00:19 swift Exp $
+EAPI="4"
+
+IUSE=""
+MODS="pan"
+BASEPOL="2.20110726-r5"
+
+inherit selinux-policy-2
+
+DESCRIPTION="SELinux policy for pan"
+KEYWORDS="~amd64 ~x86"
index 98bef4da3f4056d2843fe899f9616693272f263a..47159c58559d3fd5d04382dcf1966311c09084ad 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for sec-policy/selinux-skype
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-skype/ChangeLog,v 1.5 2011/08/28 21:12:33 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-skype/ChangeLog,v 1.6 2011/10/23 11:00:19 swift Exp $
+
+*selinux-skype-2.20110726-r2 (23 Oct 2011)
+
+  23 Oct 2011; <swift@gentoo.org> +selinux-skype-2.20110726-r2.ebuild:
+  Add support for XDG types
 
 *selinux-skype-2.20110726-r1 (28 Aug 2011)
 
diff --git a/sec-policy/selinux-skype/selinux-skype-2.20110726-r2.ebuild b/sec-policy/selinux-skype/selinux-skype-2.20110726-r2.ebuild
new file mode 100644 (file)
index 0000000..9789f4b
--- /dev/null
@@ -0,0 +1,13 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-skype/selinux-skype-2.20110726-r2.ebuild,v 1.1 2011/10/23 11:00:19 swift Exp $
+EAPI="4"
+
+IUSE=""
+MODS="skype"
+BASEPOL="2.20110726-r5"
+
+inherit selinux-policy-2
+
+DESCRIPTION="SELinux policy for skype"
+KEYWORDS="~amd64 ~x86"