dev-python/marshmallow-3.5.1: version bump, add py38
authorPatrick McLean <patrick.mclean@sony.com>
Mon, 30 Mar 2020 21:26:52 +0000 (14:26 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Mon, 30 Mar 2020 21:27:14 +0000 (14:27 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/marshmallow/Manifest
dev-python/marshmallow/marshmallow-3.5.1.ebuild [new file with mode: 0644]

index 4ffd8f6ec4b8eea2d73c993952390526909b0658..242e6214f57609c04922634ab8d4f307336b5945 100644 (file)
@@ -1,2 +1,3 @@
 DIST marshmallow-2.20.5.tar.gz 152733 BLAKE2B ba509624e3715ace53eeb1a835f533172d676b3645ae3226c6da3727dafef7084bde896f3a66459112d599e3e422d600d150934313b813fea9d819658ce3b4bf SHA512 a02b6a3341d2cd08174937112eba2f69a07de59054a088eef64ac12703699e2b6f561ce76ebc0cb43334056f02f3898098bb0d3501ae8a1b6350f9a168eb3355
 DIST marshmallow-3.0.1.tar.gz 168186 BLAKE2B 6c89fed45c144a855c692bee39390e1c80b2977274acb704095e76567e6ed00643704473f95abac7fabb4c1d1d96b90cb9a6fe3a127a09a0d2a4c72c02358baf SHA512 085a7e9b265bb86232222e4decb32fa172d62bca3ba3c5303f12715be1b0ab6553b1978e28db520a6a7a25778915c770ac83c607bdebf5e4d26746cd69f2d555
+DIST marshmallow-3.5.1.tar.gz 168839 BLAKE2B 8abf8e8d45d37794c3c615f6dac8ccd0acb76357e92ddaa4c23232b7aefba63db9bd42fb7f13dd99f9ea2ec4c7608459bc36014f9344ab91894176d0f02259c9 SHA512 89b3abce9e31dad6a20cf8ceef62270c8f95cbdf80965b6d29f1728d37d51171a020463da9d0354688183ea07e3f47a0ddab8694da13fe238f11a3dc755d4d6e
diff --git a/dev-python/marshmallow/marshmallow-3.5.1.ebuild b/dev-python/marshmallow/marshmallow-3.5.1.ebuild
new file mode 100644 (file)
index 0000000..37a0ebc
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(  python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight library for converting complex datatypes to and from native Python datatypes."
+HOMEPAGE="https://github.com/marshmallow-code/marshmallow/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/pytz[${PYTHON_USEDEP}]
+               dev-python/simplejson[${PYTHON_USEDEP}]
+       )"
+
+distutils_enable_tests pytest