www-apps/nanoc: cleanup
authorHans de Graaff <graaff@gentoo.org>
Sun, 20 Oct 2019 07:53:59 +0000 (09:53 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sun, 20 Oct 2019 12:43:22 +0000 (14:43 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
www-apps/nanoc/Manifest
www-apps/nanoc/nanoc-4.10.4.ebuild [deleted file]

index d74eefbdd6f7578ac30832492ea70ffb40b38a01..a9db2d369f443781c4a195d439f9d76b86619ef2 100644 (file)
@@ -1,4 +1,3 @@
-DIST nanoc-4.10.4.tar.gz 290367 BLAKE2B 0b5cf03938af1f971fccddb6bed4fa6b67da3aaf93cb7666c52e3ff8fc524f17ff10bf1a60ccf7f7b59f840d4c445ef57677349f5b83bc55e754e7078ac4b8d9 SHA512 5446e351906b5b6bbe5c9059dab86490d5deef5e1197adf5827fe201f2932d5cf79c65bfd9d9370ce57c35d965e013098d39d53fa96db8b4d1c6017977683ea2
 DIST nanoc-4.11.10.tar.gz 308049 BLAKE2B 8b587245d9935dad34bc0912ba65200cc6f3e8ebda00e21fc3c30e367264076d17d64fe9cc762c5ec11ab9624695f66132d5a69b29dcbf9f85fc7b0d57828592 SHA512 f4997b03834966fbda5aa28c392712ed53dda4f3d3b70b52d73e96c39612158c88f24543e0bcf74cea8ba24d108e2d64026ce3d4364f6eabbc9034ca5adf4814
 DIST nanoc-4.11.11.tar.gz 308375 BLAKE2B aed881153fb57561b62e5c5efb771777e3944232f5963dcf8bf5461802c7767b14776c161aa19bd0905b6ff5f91932d6b2ef2f0a90594e530beeac201e413568 SHA512 6db50ffb5b91e74e3d830fc8c154dcadec35376c18d8c8b909799b1d51031d307f70113f2319b1a5163ba746a2304a1aa3949e414a50e02e7396d5fd26e15a3f
 DIST nanoc-4.11.12.tar.gz 310160 BLAKE2B ef34bf6d28d5a9287053a939ef14bc59f99bde003d7bbcd7eee861ab882a6beaa48812137c8ad87fe464d27e371cfd40022467f8d10ac5f85ff16ef19215e340 SHA512 0503d0a6a0cf1ca9a9c57b831f320abb5102a3e7aa82c016d1f72c4d9f614ef53a0e4df30d50e05a98107fecacae4d70dfa5ee5c15910d575bc30df411430863
diff --git a/www-apps/nanoc/nanoc-4.10.4.ebuild b/www-apps/nanoc/nanoc-4.10.4.ebuild
deleted file mode 100644 (file)
index aeeea18..0000000
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby24"
-
-RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="nanoc is a simple but very flexible static site generator written in Ruby"
-HOMEPAGE="https://nanoc.ws/"
-SRC_URI="https://github.com/nanoc/nanoc/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE="${IUSE} minimal"
-
-DEPEND+="test? ( app-text/asciidoc app-text/highlight )"
-
-RUBY_S="${P}/nanoc"
-
-ruby_add_rdepend "!minimal? (
-       dev-ruby/mime-types:*
-       dev-ruby/rack:*
-       www-servers/adsf
-)
-       >=dev-ruby/addressable-2.5
-       >=dev-ruby/cri-2.15:0
-       dev-ruby/ddmemoize:1
-       dev-ruby/ddmetrics:1
-       dev-ruby/ddplugin:1
-       =dev-ruby/hamster-3*
-       >=dev-ruby/json_schema-0.19:0
-       >=dev-ruby/parallel-1.12:1
-       dev-ruby/ref:2
-       >=dev-ruby/slow_enumerator_tools-1.1.0:1
-       >=dev-ruby/tomlrb-1.2:1"
-
-ruby_add_bdepend "test? (
-       dev-ruby/rspec:3
-       dev-ruby/asciidoctor
-       dev-ruby/fuubar
-       dev-ruby/maruku
-       >=dev-ruby/mocha-0.13
-       dev-ruby/minitest
-       dev-ruby/pry
-       dev-ruby/rdoc
-       dev-ruby/rouge:2
-       dev-ruby/rubypants
-       dev-ruby/systemu
-       dev-ruby/timecop
-       dev-ruby/vcr
-       dev-ruby/webmock
-       dev-ruby/yard
-)
-doc? (
-       dev-ruby/kramdown
-       dev-ruby/rdiscount
-       dev-ruby/yard
-)"
-
-all_ruby_prepare() {
-       # Avoid unneeded development dependencies
-       sed -i -e '/simplecov/,/SimpleCov.formatter/ s:^:#:' test/helper.rb || die
-       sed -i -e '/simplecov/I s:^:#:' \
-               -e '/codecov/I s:^:#:' ../common/spec/spec_helper_head.rb || die
-       sed -i -e '/coverall/I s:^:#:' \
-               -e '/rubocop/ s:^:#:' Rakefile || die
-
-       echo "-r ./spec/spec_helper.rb" > .rspec || die
-
-       # Avoid tests requiring a network connection
-       rm -f test/checking/checks/test_{css,html}.rb || die
-
-       # Avoid tests for unpackaged dependencies
-       rm spec/nanoc/deploying/fog_spec.rb \
-          spec/nanoc/filters/less_spec.rb \
-          test/filters/test_{markaby,rainpress}.rb || die
-
-       # Use useable tmp dir
-       sed -i -e 's:/tmp/whatever:'${T}'/whatever:' spec/nanoc/base/checksummer_spec.rb || die
-
-       # Avoid non-fatal failing tests due to specifics in the environment
-       sed -i -e '145askip "gentoo"' spec/nanoc/cli/error_handler_spec.rb || die
-       sed -i -e '/does not crash when output dir does not exist and/askip "gentoo"' spec/nanoc/cli/commands/view_spec.rb || die
-       sed -i -e '/watches with --watch/askip "gentoo"' spec/nanoc/cli/commands/compile_spec.rb || die
-       sed -i -e '124askip "ordering issues"' -e '168askip "ordering issues"' spec/nanoc/data_sources/filesystem_spec.rb || die
-}
-
-each_ruby_test() {
-       RUBYLIB="${S}/lib" ${RUBY} -S rake spec test_all || die
-}