dev-python/terminaltables: Sync the live ebuild
authorMichał Górny <mgorny@gentoo.org>
Sun, 7 Jul 2019 12:17:14 +0000 (14:17 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 7 Jul 2019 12:17:14 +0000 (14:17 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/terminaltables/terminaltables-9999.ebuild

index eab7f76a409b4fc7d4471ff77a645a2efe6d0d42..891efcd3a4e7df1285712cb21d6e9a66786d0e03 100644 (file)
@@ -1,19 +1,30 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
 EGIT_REPO_URI="https://github.com/Robpol86/${PN}.git"
 inherit distutils-r1 git-r3
 
 DESCRIPTION="Generate simple tables in terminals from a nested list of strings"
-
 HOMEPAGE="https://robpol86.github.io/terminaltables"
 SRC_URI=""
+
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS=""
-IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/colorama[${PYTHON_USEDEP}]
+               dev-python/colorclass[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/termcolor[${PYTHON_USEDEP}]
+       )"
+
+python_test() {
+       pytest -vv || die "Tests fail with ${EPYTHON}"
+}