dev-perl/Net-DNS-SEC: bump
authorRobin H. Johnson <robbat2@gentoo.org>
Fri, 22 May 2020 19:12:38 +0000 (12:12 -0700)
committerRobin H. Johnson <robbat2@gentoo.org>
Fri, 22 May 2020 19:22:51 +0000 (12:22 -0700)
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
dev-perl/Net-DNS-SEC/Manifest
dev-perl/Net-DNS-SEC/Net-DNS-SEC-1.160.0.ebuild [new file with mode: 0644]
dev-perl/Net-DNS-SEC/metadata.xml

index 8382d4cfe6979f9b2cf0a462592da24882e32c09..d092dafadea9048ed9535d8dae7a9afefd603069 100644 (file)
@@ -1 +1,2 @@
 DIST Net-DNS-SEC-1.03.tar.gz 35605 BLAKE2B 8d7ab450986b4cc4f7d31ae50f3efdeb56e6a437269ff6a54d5ece26a863405f12faf16e52aff2ba991d6e8320ed5b5cd3d07fdee20a5b3db7da4683e02c6243 SHA512 17d9f2125b9ed687791941ea777927daf8cfe4a6a379d02cda499fb01a71606b1c01154a3d4f2f2ffb70f5a658aaf02e64c8e5cc308de8c8e0cc543271ee7bce
+DIST Net-DNS-SEC-1.16.tar.gz 46603 BLAKE2B 3f248ebe62b21c68ba06b13a13bab2b8507df4cefd10f87de88191590b05b4ed48cc04b228a78768bf3ff907d319c38eeae46d3e407180eb9722f5eb5ccf2b24 SHA512 47eaaaabfc76666a4c7da89fd9eb189fa065c7e0b60f5c166420c76226a0df938e95e5abfa83e6a1a49b92593aee078883b1a170d39426c84fdef22a2fc50ef0
diff --git a/dev-perl/Net-DNS-SEC/Net-DNS-SEC-1.160.0.ebuild b/dev-perl/Net-DNS-SEC/Net-DNS-SEC-1.160.0.ebuild
new file mode 100644 (file)
index 0000000..9409739
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=NLNETLABS
+DIST_VERSION=1.16
+inherit perl-module
+
+DESCRIPTION="DNSSEC extensions to Net::DNS"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=virtual/perl-File-Spec-0.860.0
+       >=virtual/perl-MIME-Base64-2.110.0
+       >=dev-perl/Net-DNS-1.10.0
+"
+DEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+       test? (
+               >=virtual/perl-Test-Simple-0.470.0
+       )
+"
+
+src_test() {
+       perl-module_src_test
+}
index 6117d95ae0acfd08a078286874a18bc0c050ba61..70a3cced074f6de56511e445fc0dabd0509613fc 100644 (file)
@@ -9,8 +9,10 @@
                <remote-id type="cpan">Net-DNS-SEC</remote-id>
                <remote-id type="cpan-module">Net::DNS::SEC</remote-id>
                <remote-id type="cpan-module">Net::DNS::SEC::DSA</remote-id>
+               <remote-id type="cpan-module">Net::DNS::SEC::Digest</remote-id>
                <remote-id type="cpan-module">Net::DNS::SEC::ECCGOST</remote-id>
                <remote-id type="cpan-module">Net::DNS::SEC::ECDSA</remote-id>
+               <remote-id type="cpan-module">Net::DNS::SEC::EdDSA</remote-id>
                <remote-id type="cpan-module">Net::DNS::SEC::Keyset</remote-id>
                <remote-id type="cpan-module">Net::DNS::SEC::Private</remote-id>
                <remote-id type="cpan-module">Net::DNS::SEC::RSA</remote-id>