net-p2p/transmission: Fix build with miniupnpc API 14
authorMike Gilbert <floppym@gentoo.org>
Sat, 3 Oct 2015 18:26:23 +0000 (14:26 -0400)
committerMike Gilbert <floppym@gentoo.org>
Sat, 3 Oct 2015 18:26:34 +0000 (14:26 -0400)
Thanks to Sander Sweers for the patch.

Bug: https://bugs.gentoo.org/562020

Package-Manager: portage-2.2.22_p5

net-p2p/transmission/files/2.84-miniupnp14.patch [new file with mode: 0644]
net-p2p/transmission/transmission-2.84-r1.ebuild
net-p2p/transmission/transmission-2.84.ebuild

diff --git a/net-p2p/transmission/files/2.84-miniupnp14.patch b/net-p2p/transmission/files/2.84-miniupnp14.patch
new file mode 100644 (file)
index 0000000..7e531cc
--- /dev/null
@@ -0,0 +1,23 @@
+libtransmission: Build fix for miniupnp API version 14
+
+Patch by Sander Sweers <Sander.Sweers@gmail.com>
+
+Bug: https://bugs.gentoo.org/562020
+Index: libtransmission/upnp.c
+===================================================================
+--- libtransmission/upnp.c     (revision 14564)
++++ libtransmission/upnp.c     (working copy)
+@@ -86,8 +86,12 @@
+   struct UPNPDev * ret;
+   bool have_err;
+-#if (MINIUPNPC_API_VERSION >= 8) /* adds ipv6 and error args */
++#if (MINIUPNPC_API_VERSION >= 14) /* adds ttl */
+   int err = UPNPDISCOVER_SUCCESS;
++  ret = upnpDiscover (msec, NULL, NULL, 0, 0, 2, &err);
++  have_err = err != UPNPDISCOVER_SUCCESS;
++#elif (MINIUPNPC_API_VERSION >= 8) /* adds ipv6 and error args */
++  int err = UPNPDISCOVER_SUCCESS;
+   ret = upnpDiscover (msec, NULL, NULL, 0, 0, &err);
+   have_err = err != UPNPDISCOVER_SUCCESS;
+ #else
index 9cbecb41267b6c9f12ad3d22014a156b46fef36b..97a3a72001eb7c3a78c81b0913cf3758ef6a6ced 100644 (file)
@@ -72,6 +72,8 @@ src_prepare() {
        # http://trac.transmissionbt.com/ticket/5700
        sed -i -e '1iQMAKE_CXXFLAGS += -std=c++11' qt/qtr.pro || die
 
+       epatch "${FILESDIR}/2.84-miniupnp14.patch"
+
        epatch_user
        eautoreconf
 }
index 8af517cf0491d1293aaf96286fd399aa2f590826..d1648c448a7965c5e5870c1b5f8913399030a3cb 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -65,6 +65,8 @@ src_prepare() {
        # http://trac.transmissionbt.com/ticket/5700
        sed -i -e '1iQMAKE_CXXFLAGS += -std=c++11' qt/qtr.pro || die
 
+       epatch "${FILESDIR}/2.84-miniupnp14.patch"
+
        epatch_user
        eautoreconf
 }