media-libs/libepoxy: Version bump to 1.3.1.
authorMatt Turner <mattst88@gentoo.org>
Sat, 26 Sep 2015 05:39:12 +0000 (22:39 -0700)
committerMatt Turner <mattst88@gentoo.org>
Sat, 26 Sep 2015 05:39:37 +0000 (22:39 -0700)
Bug: https://bugs.gentoo.org/561422

media-libs/libepoxy/Manifest
media-libs/libepoxy/libepoxy-1.3.1.ebuild [new file with mode: 0644]

index fcc755633e8387c70391abcd248266b531055aa4..d13085465137f1884d463c29085ae8ba783679b5 100644 (file)
@@ -1 +1,2 @@
 DIST libepoxy-1.2.tar.gz 267110 SHA256 42c328440f60a5795835c5ec4bdfc1329e75bba16b6e22b3a87ed17e9679e8f6 SHA512 1104fc7e6cbb4bb95e422e7801491067806df6849690be4068b5eec33a5fc84672a5bb4666357e9a46d2fae436f83b37402b6cc0c4ee69627e48d48a4d32a2ed WHIRLPOOL 6a678b9999a909a858a6bd6d9695fd1b6093cd266c1b8c72c401c880a11c09aa9e819ec1459fd12e997ecf54460d7b1da0c476f79d27539218533fff53fc78a6
+DIST libepoxy-1.3.1.tar.gz 284227 SHA256 6700ddedffb827b42c72cce1e0be6fba67b678b19bf256e1b5efd3ea38cc2bb4 SHA512 7d83f01bbc6d2387e4e2ec8a94b05d6e7aa6d0513821a794d60544381a18874fa75ec1dfd2585824076708e2848ff8d5dc20e184af65a7cb602e7dfd010aaf53 WHIRLPOOL 2a91c3e0931b57e791a91f025c7e9b21d6404d9644a7dc47faf6b64a3f17838dc509d1860d38be9c08779ac35fb9c56606396fc02ccccc5833d4aaf78cfcc359
diff --git a/media-libs/libepoxy/libepoxy-1.3.1.ebuild b/media-libs/libepoxy/libepoxy-1.3.1.ebuild
new file mode 100644 (file)
index 0000000..aadac36
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+EGIT_REPO_URI="git://github.com/anholt/libepoxy.git"
+
+if [[ ${PV} = 9999* ]]; then
+       GIT_ECLASS="git-r3"
+fi
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='xml(+)'
+inherit autotools-multilib ${GIT_ECLASS} python-any-r1
+
+DESCRIPTION="Epoxy is a library for handling OpenGL function pointer management for you"
+HOMEPAGE="https://github.com/anholt/libepoxy"
+if [[ ${PV} = 9999* ]]; then
+       KEYWORDS=""
+       SRC_URI=""
+else
+       KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+       SRC_URI="https://github.com/anholt/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTICT="test" # FIXME: tests fail when run from portage.
+
+DEPEND="${PYTHON_DEPS}
+       media-libs/mesa[egl]
+       x11-misc/util-macros
+       x11-libs/libX11"
+RDEPEND=""
+
+src_unpack() {
+       default
+       [[ $PV = 9999* ]] && git-r3_src_unpack
+}