version bump
authorBrandon Hale <tseng@gentoo.org>
Wed, 10 Sep 2003 02:16:08 +0000 (02:16 +0000)
committerBrandon Hale <tseng@gentoo.org>
Wed, 10 Sep 2003 02:16:08 +0000 (02:16 +0000)
x11-wm/fluxbox/Manifest
x11-wm/fluxbox/files/digest-fluxbox-0.9.6_pre4 [new file with mode: 0644]
x11-wm/fluxbox/fluxbox-0.9.6_pre4.ebuild [new file with mode: 0644]
x11-wm/fluxbox/metadata.xml [new file with mode: 0644]

index 6832ce23d48424cce856c82d5db564da6a938c47..4d06e3b30f0aa484d4129ca6996783af16ead3eb 100644 (file)
@@ -5,8 +5,9 @@ MD5 143110b2a988e0a383142062b0fa41b6 fluxbox-0.9.3.ebuild 2718
 MD5 584949bdc5b17f5f5219e820d739c815 fluxbox-0.9.4.ebuild 2718
 MD5 05b1b1b37d0da0bcbe5f826a04430791 fluxbox-0.9.5.ebuild 2718
 MD5 0dc4300bf996697cc40e684b63c63bc1 fluxbox-0.9.6_pre1.ebuild 2744
-MD5 1a97aa773eff9a85c4b13cccbda1de69 ChangeLog 14014
-MD5 0dc4300bf996697cc40e684b63c63bc1 fluxbox-0.9.6_pre4.ebuild 2744
+MD5 7d2823606df9408d8c203ad66e587aa2 fluxbox-0.9.6_pre4.ebuild 2742
+MD5 416452bedba085c06bd2502510370e1a metadata.xml 162
+MD5 213779a1f627573e902518eb7c792e48 ChangeLog 14172
 MD5 3661fa0f4811d5de5119163ee43ac690 files/digest-fluxbox-0.1.12-r1 132
 MD5 1c3ae2ce22f7f2a778a8ad5a5631df28 files/digest-fluxbox-0.1.14-r1 67
 MD5 224efa97a7e52718fb828c036c6d91d9 files/digest-fluxbox-0.9.0 65
diff --git a/x11-wm/fluxbox/files/digest-fluxbox-0.9.6_pre4 b/x11-wm/fluxbox/files/digest-fluxbox-0.9.6_pre4
new file mode 100644 (file)
index 0000000..00dc2cc
--- /dev/null
@@ -0,0 +1,2 @@
+MD5 a956d88e701f6ee869ee9894abde5650 fluxbox-0.9.6pre1.tar.gz 623189
+MD5 f6fa316baa5aa593c7bc4c40ac7e4517 blueflux_0.1.0.tar.gz 17601
diff --git a/x11-wm/fluxbox/fluxbox-0.9.6_pre4.ebuild b/x11-wm/fluxbox/fluxbox-0.9.6_pre4.ebuild
new file mode 100644 (file)
index 0000000..0c71b84
--- /dev/null
@@ -0,0 +1,94 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-0.9.6_pre4.ebuild,v 1.1 2003/09/10 02:16:03 tseng Exp $
+
+IUSE="gnome kde nls xinerama truetype"
+
+#inherit flag-o-matic eutils
+
+MY_P="${PN}-0.9.6pre1"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Fluxbox is yet another windowmanager for X. It's based on the Blackbox 0.61.1 code. Fluxbox looks like blackbox and handles styles, colors, window placement and similar thing exactly like blackbox (100% theme/style compability). So what's the difference between fluxbox and blackbox then? The answer is: LOTS! *This is a development release and should not be considered stable.* *This release includes the Blueflux style.*"
+SRC_URI="http://fluxbox.org/download/${MY_P}.tar.gz
+       http://koti.mbnet.fi/bionik/blueflux/blueflux_0.1.0.tar.gz"
+HOMEPAGE="http://www.fluxbox.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="virtual/x11
+               >=sys-devel/autoconf-2.52"
+RDEPEND="x11-misc/commonbox-utils
+               x11-themes/commonbox-styles"
+PROVIDE="virtual/blackbox"
+
+mydoc="ChangeLog COPYING NEWS"
+
+src_unpack() {
+
+       unpack ${A}
+       cd ${S}
+
+       use nls && ( \
+               einfo "Redirecting NLS"
+               for i in `find ${S} -name 'Makefile.am'`
+               do
+                       sed -i -e 's:$(pkgdatadir)/nls:/usr/share/locale:' ${i}
+               done
+       )
+
+       sed -i -e 's:bsetroot.1::' ${S}/doc/Makefile.am
+       sed -i -e 's:bsetroot::' ${S}/util/Makefile.*
+}
+
+
+src_compile() {
+
+       econf \
+               `use_enable nls` \
+               `use_enable kde` \
+               `use_enable gnome` \
+               `use_enable xinerama` \
+               `use_enable truetype xft` \
+               --sysconfdir=/etc/X11/${PN} \
+               --datadir=/usr/share/commonbox \
+               ${myconf} || die
+
+       sed -i -e 's:\$(datadir)/fluxbox:/usr/share/commonbox:' ${S}/Makefile
+       sed -i -e 's:\$(datadir)/fluxbox:/usr/share/commonbox:' ${S}/data/Makefile
+
+       emake \
+               pkgdatadir=/usr/share/commonbox || die
+
+       cd data make \
+               pkgdatadir=/usr/share/commonbox init
+}
+
+src_install() {
+
+       dodir /usr/share/commonbox/${PN}
+       dodir /usr/share/commonbox/styles
+       make DESTDIR=${D} install || die
+       dodoc README* AUTHORS TODO* ${mydoc}
+       rmdir ${D}/usr/share/${PN}
+       dodir /etc/X11/Sessions
+       echo "/usr/bin/${PN}" > ${D}/etc/X11/Sessions/${PN}
+       fperms a+x /etc/X11/Sessions/${PN}
+
+       cd data
+       insinto /usr/share/commonbox
+       doins init keys
+       insinto /usr/share/commonbox/styles
+       doins ${D}/usr/share/commonbox/fluxbox/styles/Meta
+       rm -rf ${D}/usr/share/commonbox/fluxbox
+
+       # blueflux style
+       insinto /usr/share/commonbox/pixmaps
+       doins ${WORKDIR}/pixmaps/*
+       # fix some paths and change b->B at the same time
+       sed -e 's:\.fluxbox:/usr/share/commonbox:' ${WORKDIR}/styles/blueflux \
+               > ${WORKDIR}/styles/Blueflux
+       insinto /usr/share/commonbox/styles
+       doins ${WORKDIR}/styles/Blueflux
+}
diff --git a/x11-wm/fluxbox/metadata.xml b/x11-wm/fluxbox/metadata.xml
new file mode 100644 (file)
index 0000000..682bce3
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>commonbox</herd>
+</pkgmetadata>