sys-apps/portage: convert USE zstd to USE flag binpkg-zstd
authorIan Leonard <antonlacon@gmail.com>
Thu, 7 May 2020 15:51:38 +0000 (08:51 -0700)
committerZac Medico <zmedico@gentoo.org>
Thu, 7 May 2020 16:12:27 +0000 (09:12 -0700)
Bug: https://bugs.gentoo.org/715108
Bug: https://bugs.gentoo.org/719456
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Ian Leonard <antonlacon@gmail.com>
Signed-off-by: Zac Medico <zmedico@gentoo.org>
profiles/arch/riscv/package.use.mask
sys-apps/portage/metadata.xml
sys-apps/portage/portage-9999.ebuild

index bb0fdc58ad0c7bbe2655b9ba3d88facf36875cea..e1c7c4fe544c3b698f367470999843c98c9e7c67 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 2019-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-# Zac Medico <zmedico@gentoo.org> (2020-05-05)
+# Zac Medico <zmedico@gentoo.org> (2020-05-07)
 # Mask until app-arch/zstd is keyworded
-sys-apps/portage zstd
+sys-apps/portage binpkg-zstd
 
 # Patrick McLean <chutzpah@gentoo.org> (2020-04-16)
 # Lots of python dependencies, mask to facilitate keywording
index 062dafe62481ecf7cefd3f0199282fda23fc8da8..0f9d932ce5e73d50a5798505a2b336ae79054ef4 100644 (file)
@@ -12,6 +12,7 @@
   </maintainer>
   <use>
     <flag name="apidoc">Build html API documentation with sphinx-apidoc.</flag>
+    <flag name="binpkg-zstd">Use zstd compression with creating binary packages.</flag>
     <flag name="gentoo-dev">Enable features required for Gentoo ebuild development.</flag>
     <flag name="ipc">Use inter-process communication between portage and
         running ebuilds.
index e8b41acd67ab0ca15bb0a80cb4c8481be632cf62..f5da3ae281b446c3f4c72e11c2739a56d5b6352d 100644 (file)
@@ -15,7 +15,7 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
 LICENSE="GPL-2"
 KEYWORDS=""
 SLOT="0"
-IUSE="apidoc build doc gentoo-dev +ipc +native-extensions +rsync-verify selinux xattr zstd"
+IUSE="apidoc binpkg-zstd build doc gentoo-dev +ipc +native-extensions +rsync-verify selinux xattr"
 
 DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') )
        >=app-arch/tar-1.27
@@ -53,7 +53,7 @@ RDEPEND="
        xattr? ( kernel_linux? (
                >=sys-apps/install-xattr-0.3
        ) )
-       zstd? ( app-arch/zstd )
+       binpkg-zstd? ( app-arch/zstd )
        !<app-admin/logrotate-3.8.0"
 PDEPEND="
        !build? (
@@ -115,7 +115,7 @@ python_prepare_all() {
                        || die "failed to append to make.globals"
        fi
 
-       if use zstd ; then
+       if use binpkg-zstd ; then
                einfo "Adding BINGPKG_COMPRESS=\"zstd\" to make.globals ..."
                echo -e '\nBINGPKG_COMPRESS="zstd"' >> cnf/make.globals \
                        || die "failed to append to make.globals"