net-dialup/dwun: Fix building with CFLAGS=-fno-common
authorJeroen Roovers <jer@gentoo.org>
Sun, 17 May 2020 11:08:20 +0000 (13:08 +0200)
committerJeroen Roovers <jer@gentoo.org>
Sun, 17 May 2020 11:09:19 +0000 (13:09 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Closes: https://bugs.gentoo.org/706982
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-dialup/dwun/dwun-0.96e-r4.ebuild
net-dialup/dwun/files/dwun-0.96e-fno-common.patch [new file with mode: 0644]

index fbc86601b4169b2118289b44bce995816f9b8725..aa99a75ba5ee0f1fe1c8c6a636d848dbc198f328 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -16,6 +16,8 @@ KEYWORDS="~amd64 x86"
 DOCS=( AUTHORS ChangeLog QUICKSTART README TODO UPGRADING )
 
 src_prepare() {
+       eapply "${FILESDIR}"/${P}-fno-common.patch
+
        sed -i -e "s:TODO QUICKSTART README UPGRADING ChangeLog COPYING AUTHORS::" Makefile.in || die
        tc-export CC
 
diff --git a/net-dialup/dwun/files/dwun-0.96e-fno-common.patch b/net-dialup/dwun/files/dwun-0.96e-fno-common.patch
new file mode 100644 (file)
index 0000000..c84c027
--- /dev/null
@@ -0,0 +1,41 @@
+--- a/src/main.c
++++ b/src/main.c
+@@ -37,11 +37,11 @@
+ /* extern'ed in main.h */
+ struct settings set;
+ char *error_messages;
++enum MYLOG_OPTIONS MYLOG_OPTIONS = MYLOG_STDERR;
+ int main(int argc, char *argv[]) 
+ {
+       char orig_work_dir[MAXPATHLEN];
+-      MYLOG_OPTIONS = MYLOG_STDERR;
+       umask(022); /* -rw-r--r- */
+       if (!(error_messages = xmalloc(MAX_LOG_LENGTH)))
+--- a/src/shared.h
++++ b/src/shared.h
+@@ -56,10 +56,11 @@
+       char *external;                 /* named pipe (optional) */
+ };
+-enum {
++enum MYLOG_OPTIONS {
+       MYLOG_STDERR,
+       MYLOG_STDERR_DATEPID,
+       MYLOG_SYSLOG
+-} MYLOG_OPTIONS;
++};
++extern enum MYLOG_OPTIONS MYLOG_OPTIONS;
+ #endif
+--- a/src/util.c
++++ b/src/util.c
+@@ -26,6 +26,7 @@
+ #include "util.h"
+ #include "child.h"
+ #include "main.h"
++#include "shared.h"
+ static bool create_file(char *file, int options);
+ static void print_date_pid(void);