dev-libs/libwapcaplet: drop netsurf eclass
authorVirgil Dupras <vdupras@gentoo.org>
Tue, 13 Nov 2018 16:29:52 +0000 (11:29 -0500)
committerVirgil Dupras <vdupras@gentoo.org>
Tue, 13 Nov 2018 18:04:21 +0000 (13:04 -0500)
Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-libs/libwapcaplet/Manifest
dev-libs/libwapcaplet/libwapcaplet-0.4.1-r1.ebuild [new file with mode: 0644]
dev-libs/libwapcaplet/libwapcaplet-0.4.1.ebuild [deleted file]

index 42f809eb6e26352bcf9474c62e53e81e7534aa9b..72e8840dac506bae0347c85a28ab34b405253b7c 100644 (file)
@@ -1,2 +1 @@
 DIST libwapcaplet-0.4.1-src.tar.gz 31448 BLAKE2B a686a357dc84135da902380de17b0f8415a682cdb258ea0a8f7899581d23f6fef3aa1600e2657aa728b5689a8fa31a3fe489a7ce8a339adf958c3c25f6151a04 SHA512 49efb958ee79e932916a956844970780723cc71b4b2e5f442507566b2d632cc17c67d984018b48ae31a9bd7d92797766e39110dec02937b45ead26523e8cc2e1
-DIST netsurf-buildsystem-1.7.tar.gz 38597 BLAKE2B d0981ef282ac0d93d81a1a6a6bee1fc2a0151c962be6ce2900a67843ba8ebc67e00508cded2a7375f6bbe0d45572690f127872936a282de80eb08655ac571603 SHA512 f6a46ac25f41e695ec13d7b2b564250c4cc44a40a688904eb17aa4b547c2df0102cc0effb7a23a2ffa6b9178ae5cf452b63980caf26e06e479168c85803f1e58
diff --git a/dev-libs/libwapcaplet/libwapcaplet-0.4.1-r1.ebuild b/dev-libs/libwapcaplet/libwapcaplet-0.4.1-r1.ebuild
new file mode 100644 (file)
index 0000000..dd35cf9
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="string internment library, written in C"
+HOMEPAGE="http://www.netsurf-browser.org/projects/libwapcaplet/"
+SRC_URI="https://download.netsurf-browser.org/libs/releases/${P}-src.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~ppc ~m68k-mint"
+IUSE="test"
+
+DEPEND="
+       dev-util/netsurf-buildsystem
+       test? ( >=dev-libs/check-0.9.11 )"
+
+PATCHES=(
+       # bug 664288
+       "${FILESDIR}/${PN}-0.4.1-makefile.patch"
+)
+
+_emake() {
+       source /usr/share/netsurf-buildsystem/gentoo-helpers.sh
+       netsurf_define_makeconf
+       emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=lib-shared $@
+}
+
+src_compile() {
+       _emake
+}
+
+src_test() {
+       _emake test
+}
+
+src_install() {
+       _emake DESTDIR="${ED}" install
+}
diff --git a/dev-libs/libwapcaplet/libwapcaplet-0.4.1.ebuild b/dev-libs/libwapcaplet/libwapcaplet-0.4.1.ebuild
deleted file mode 100644 (file)
index 4e1c13d..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-NETSURF_BUILDSYSTEM=buildsystem-1.7
-inherit netsurf
-
-DESCRIPTION="string internment library, written in C"
-HOMEPAGE="http://www.netsurf-browser.org/projects/libwapcaplet/"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm ~ppc ~m68k-mint"
-IUSE="test"
-
-DEPEND="test? ( >=dev-libs/check-0.9.11[${MULTILIB_USEDEP}] )"
-
-PATCHES=(
-       # bug 664288
-       "${FILESDIR}/${PN}-0.4.1-makefile.patch"
-)
-
-src_prepare() {
-       # working around broken netsurf eclass
-       default
-       multilib_copy_sources
-}