dev-python/jaraco-itertools: add Python 3.7, more verbose tests
authorLouis Sautier <sbraz@gentoo.org>
Wed, 25 Jul 2018 21:10:11 +0000 (23:10 +0200)
committerLouis Sautier <sbraz@gentoo.org>
Wed, 25 Jul 2018 21:10:11 +0000 (23:10 +0200)
Package-Manager: Portage-2.3.43, Repoman-2.3.10

dev-python/jaraco-itertools/jaraco-itertools-2.4.ebuild

index 239e74badaed5be4080b68e2b7ee4b0354a3e109..86d3ccea6157b69d3c11fe31e5d2800d0dab1406 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 # Tests fail with PyPy and PyPy 3
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
 
 inherit distutils-r1
 
@@ -49,7 +49,7 @@ python_compile_all() {
 
 python_test() {
        # Override pytest options to skip flake8
-       PYTHONPATH=. py.test --override-ini="addopts=--doctest-modules" \
+       PYTHONPATH=. pytest -v --override-ini="addopts=--doctest-modules" \
                || die "tests failed with ${EPYTHON}"
 }