net-mail/mailbase: Drop old (EAPI 0)
authorMichał Górny <mgorny@gentoo.org>
Sat, 12 Oct 2019 07:04:47 +0000 (09:04 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 12 Oct 2019 07:06:27 +0000 (09:06 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-mail/mailbase/mailbase-1.1.ebuild [deleted file]
net-mail/mailbase/mailbase-1.3.ebuild [deleted file]
net-mail/mailbase/mailbase-1.4.ebuild [deleted file]
net-mail/mailbase/mailbase-1.5.ebuild [deleted file]

diff --git a/net-mail/mailbase/mailbase-1.1.ebuild b/net-mail/mailbase/mailbase-1.1.ebuild
deleted file mode 100644 (file)
index b3d45a2..0000000
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit pam eutils user
-
-DESCRIPTION="MTA layout package"
-SRC_URI=""
-HOMEPAGE="https://www.gentoo.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="pam"
-
-RDEPEND="pam? ( virtual/pam )"
-
-S=${WORKDIR}
-
-pkg_setup() {
-       enewgroup mail 12
-       enewuser mail 8 -1 /var/spool/mail mail
-       enewuser postmaster 14 -1 /var/spool/mail
-}
-
-src_install() {
-       dodir /etc/mail
-       insinto /etc/mail
-       doins "${FILESDIR}"/aliases || die
-       insinto /etc
-       doins "${FILESDIR}"/mailcap || die
-
-       keepdir /var/spool/mail
-       fowners root:mail /var/spool/mail
-       fperms 03775 /var/spool/mail
-       dosym /var/spool/mail /var/mail
-
-       newpamd "${FILESDIR}"/common-pamd-include pop
-       newpamd "${FILESDIR}"/common-pamd-include imap
-       if use pam ; then
-               local p
-               for p in pop3 pop3s pops ; do
-                       dosym pop /etc/pam.d/${p} || die
-               done
-               for p in imap4 imap4s imaps ; do
-                       dosym imap /etc/pam.d/${p} || die
-               done
-       fi
-}
-
-get_permissions_oct() {
-       if [[ ${USERLAND} = GNU ]] ; then
-               stat -c%a "${ROOT}$1"
-       elif [[ ${USERLAND} = BSD ]] ; then
-               stat -f%p "${ROOT}$1" | cut -c 3-
-       fi
-}
-
-pkg_postinst() {
-       if [[ "$(get_permissions_oct /var/spool/mail)" != "3775" ]] ; then
-               echo
-               ewarn "Your ${ROOT}var/spool/mail/ directory permissions differ from"
-               ewarn "  those which mailbase wants to set it to (03775)."
-               ewarn "  If you did not change them on purpose, consider running:"
-               ewarn
-               ewarn "    chown root:mail ${ROOT}var/spool/mail/"
-               ewarn "    chmod 03775 ${ROOT}var/spool/mail/"
-               echo
-       fi
-}
diff --git a/net-mail/mailbase/mailbase-1.3.ebuild b/net-mail/mailbase/mailbase-1.3.ebuild
deleted file mode 100644 (file)
index 817fdca..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit pam eutils user
-
-DESCRIPTION="MTA layout package"
-SRC_URI=""
-HOMEPAGE="https://www.gentoo.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="pam"
-
-RDEPEND="pam? ( virtual/pam )"
-
-S=${WORKDIR}
-
-pkg_setup() {
-       enewgroup mail 12
-       enewuser mail 8 -1 /var/spool/mail mail
-       enewuser postmaster 14 -1 /var/spool/mail
-}
-
-src_install() {
-       dodir /etc/mail
-       insinto /etc/mail
-       doins "${FILESDIR}"/aliases
-       insinto /etc
-       doins "${FILESDIR}"/mailcap
-
-       keepdir /var/spool/mail
-       fowners root:mail /var/spool/mail
-       fperms 03775 /var/spool/mail
-       dosym spool/mail /var/mail
-
-       newpamd "${FILESDIR}"/common-pamd-include pop
-       newpamd "${FILESDIR}"/common-pamd-include imap
-       if use pam ; then
-               local p
-               for p in pop3 pop3s pops ; do
-                       dosym pop /etc/pam.d/${p}
-               done
-               for p in imap4 imap4s imaps ; do
-                       dosym imap /etc/pam.d/${p}
-               done
-       fi
-}
-
-get_permissions_oct() {
-       if [[ ${USERLAND} = GNU ]] ; then
-               stat -c%a "${ROOT}$1"
-       elif [[ ${USERLAND} = BSD ]] ; then
-               stat -f%p "${ROOT}$1" | cut -c 3-
-       fi
-}
-
-pkg_postinst() {
-       # bug 614396
-       if [[ "$(get_permissions_oct /var/spool/mail)" != "3775" ]] ; then
-               einfo  "Fixing ${ROOT}var/spool/mail/ permissions"
-               chown root:mail "${ROOT}var/spool/mail/"
-               chmod 03775 "${ROOT}var/spool/mail/"
-       fi
-}
diff --git a/net-mail/mailbase/mailbase-1.4.ebuild b/net-mail/mailbase/mailbase-1.4.ebuild
deleted file mode 100644 (file)
index f2b5eb9..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit pam user
-
-DESCRIPTION="MTA layout package"
-SRC_URI=""
-HOMEPAGE="https://www.gentoo.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="pam"
-
-RDEPEND="pam? ( virtual/pam )"
-
-S=${WORKDIR}
-
-pkg_setup() {
-       enewgroup mail 12
-       enewuser mail 8 -1 /var/spool/mail mail
-       enewuser postmaster 14 -1 /var/spool/mail
-}
-
-src_install() {
-       dodir /etc/mail
-       insinto /etc/mail
-       doins "${FILESDIR}"/aliases
-       insinto /etc
-       doins "${FILESDIR}"/mailcap
-       doman "${FILESDIR}"/mailcap.5
-
-       keepdir /var/spool/mail
-       fowners root:mail /var/spool/mail
-       fperms 03775 /var/spool/mail
-       dosym spool/mail /var/mail
-
-       newpamd "${FILESDIR}"/common-pamd-include pop
-       newpamd "${FILESDIR}"/common-pamd-include imap
-       if use pam ; then
-               local p
-               for p in pop3 pop3s pops ; do
-                       dosym pop /etc/pam.d/${p}
-               done
-               for p in imap4 imap4s imaps ; do
-                       dosym imap /etc/pam.d/${p}
-               done
-       fi
-}
-
-get_permissions_oct() {
-       if [[ ${USERLAND} = GNU ]] ; then
-               stat -c%a "${ROOT}$1"
-       elif [[ ${USERLAND} = BSD ]] ; then
-               stat -f%p "${ROOT}$1" | cut -c 3-
-       fi
-}
-
-pkg_postinst() {
-       # bug 614396
-       if [[ "$(get_permissions_oct /var/spool/mail)" != "3775" ]] ; then
-               einfo  "Fixing ${ROOT}/var/spool/mail/ permissions"
-               chown root:mail "${ROOT}/var/spool/mail/"
-               chmod 03775 "${ROOT}/var/spool/mail/"
-       fi
-}
diff --git a/net-mail/mailbase/mailbase-1.5.ebuild b/net-mail/mailbase/mailbase-1.5.ebuild
deleted file mode 100644 (file)
index 4baa774..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit pam user
-
-DESCRIPTION="MTA layout package"
-SRC_URI=""
-HOMEPAGE="https://www.gentoo.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="pam"
-
-RDEPEND="pam? ( virtual/pam )"
-
-S=${WORKDIR}
-
-pkg_setup() {
-       enewgroup mail 12
-       enewuser mail 8 -1 /var/spool/mail mail
-       enewuser postmaster 14 -1 /var/spool/mail
-}
-
-src_install() {
-       dodir /etc/mail
-       insinto /etc/mail
-       doins "${FILESDIR}"/aliases
-       insinto /etc
-       doins "${FILESDIR}"/mailcap
-       doman "${FILESDIR}"/mailcap.5
-
-       keepdir /var/spool/mail
-       fowners root:mail /var/spool/mail
-       fperms 03775 /var/spool/mail
-       dosym spool/mail /var/mail
-
-       newpamd "${FILESDIR}"/common-pamd-include pop
-       newpamd "${FILESDIR}"/common-pamd-include imap
-       if use pam ; then
-               local p
-               for p in pop3 pop3s pops ; do
-                       dosym pop /etc/pam.d/${p}
-               done
-               for p in imap4 imap4s imaps ; do
-                       dosym imap /etc/pam.d/${p}
-               done
-       fi
-}
-
-get_permissions_oct() {
-       if [[ ${USERLAND} = GNU ]] ; then
-               stat -c%a "${ROOT}$1"
-       elif [[ ${USERLAND} = BSD ]] ; then
-               stat -f%p "${ROOT}$1" | cut -c 3-
-       fi
-}
-
-pkg_postinst() {
-       # bug 614396
-       if [[ "$(get_permissions_oct /var/spool/mail)" != "3775" ]] ; then
-               einfo  "Fixing ${ROOT}/var/spool/mail/ permissions"
-               chown root:mail "${ROOT}/var/spool/mail/"
-               chmod 03775 "${ROOT}/var/spool/mail/"
-       fi
-}