dev-haskell/missingh: allow ghc-8
authorSergei Trofimovich <slyfox@gentoo.org>
Tue, 10 May 2016 21:50:16 +0000 (22:50 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Wed, 11 May 2016 08:48:03 +0000 (09:48 +0100)
Package-Manager: portage-2.2.28

dev-haskell/missingh/files/missingh-1.3.0.1-ghc-8.0.patch [new file with mode: 0644]
dev-haskell/missingh/missingh-1.3.0.1.ebuild

diff --git a/dev-haskell/missingh/files/missingh-1.3.0.1-ghc-8.0.patch b/dev-haskell/missingh/files/missingh-1.3.0.1-ghc-8.0.patch
new file mode 100644 (file)
index 0000000..ac45639
--- /dev/null
@@ -0,0 +1,25 @@
+--- MissingH-1.3.0.1-orig/src/Data/BinPacking.hs       2014-10-28 23:46:24.000000000 +1100
++++ MissingH-1.3.0.1/src/Data/BinPacking.hs    2016-04-20 10:23:16.403505044 +1000
+@@ -69,7 +69,7 @@
+ > [(size, obj)] is the sizes and objects
+ > result is Either error or results
+ -}
+-type BinPacker = (Num size, Ord size, Show size, Show obj) => 
++type BinPacker = forall size obj . (Num size, Ord size, Show size, Show obj) => 
+                   [size]        -- The sizes of bins
+                -> [(size, obj)] -- The sizes and objects
+                -> Either (BinPackerError size obj) [[(size, obj)]] -- Either error or results
+--- MissingH-1.3.0.1-orig/src/System/IO/HVFS.hs        2014-10-28 23:46:24.000000000 +1100
++++ MissingH-1.3.0.1/src/System/IO/HVFS.hs     2016-04-24 18:50:36.893741944 +1000
+@@ -60,7 +60,10 @@
+ import System.IO.PlafCompat
+ import System.Posix.Types
+ import System.Time
+-import System.Directory
++import System.Directory (createDirectory, doesDirectoryExist, doesFileExist,
++                         getCurrentDirectory, getDirectoryContents, getModificationTime,
++                         removeDirectory, removeFile, renameDirectory,
++                         renameFile, setCurrentDirectory)
+ #if MIN_VERSION_directory(1,2,0)
+ import Data.Time.Clock.POSIX ( utcTimeToPOSIXSeconds )
index b76a2e529247fe06a0fcc82076d94a1d57684028..08df029dfdf786c4bf34cd94c24bc18ea1bb2188 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -39,3 +39,7 @@ DEPEND="${RDEPEND}
 "
 
 S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+       epatch "${FILESDIR}/${PN}-1.3.0.1-ghc-8.0.patch"
+}