app-text/mupdf: use bundled mujs
authorVirgil Dupras <vdupras@gentoo.org>
Tue, 7 May 2019 11:30:20 +0000 (07:30 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Tue, 7 May 2019 11:31:26 +0000 (07:31 -0400)
Fixes broken building process.

Closes: https://bugs.gentoo.org/685244
Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

app-text/mupdf/mupdf-1.15.0.ebuild

index 258ffd7680265ef4641c38d332d26ae1865e8b69..440a343441f53e9c539b96e144fd8ea9a8963f84 100644 (file)
@@ -15,7 +15,6 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~amd64-li
 IUSE="X +javascript libressl opengl ssl static-libs vanilla"
 
 RDEPEND="
-       >=dev-lang/mujs-1.0.4
        media-libs/freetype:2=[static-libs?]
        media-libs/harfbuzz:=[static-libs?,truetype]
        media-libs/jbig2dec:=[static-libs?]
@@ -73,15 +72,20 @@ src_prepare() {
 
 _emake() {
        # When HAVE_OBJCOPY is yes, we end up with a lot of QA warnings.
+
        # We don't use system's freeglut because upstream has a special modified
        # version of it that gives mupdf clipboard support. See bug #653298
+
+       # As of v1.15.0, mupdf started using symbols in mujs that were not part
+       # of any release. We thus go back to using the bundled version of it.
+       # Bug #685244
        emake \
                GENTOO_PV=${PV} \
                HAVE_GLUT=$(usex opengl) \
                HAVE_LIBCRYPTO=$(usex ssl) \
                HAVE_X11=$(usex X) \
                USE_SYSTEM_LIBS=yes \
-               USE_SYSTEM_MUJS=yes \
+               USE_SYSTEM_MUJS=no \
                USE_SYSTEM_GLUT=no \
                HAVE_OBJCOPY=no \
                "$@"