app-crypt/tpm2-tools: Bump version to 4.1.1
authorSalah Coronya <salah.coronya@gmail.com>
Thu, 20 Feb 2020 02:06:06 +0000 (20:06 -0600)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 26 Feb 2020 16:17:24 +0000 (18:17 +0200)
Closes: https://bugs.gentoo.org/694988
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Salah Coronya <salah.coronya@gmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-crypt/tpm2-tools/Manifest
app-crypt/tpm2-tools/files/tpm2-tools-4.1.1-libressl.patch [new file with mode: 0644]
app-crypt/tpm2-tools/tpm2-tools-4.1.1.ebuild [new file with mode: 0644]

index fe23dab9fc3bde8ea6b69f0c080b7dd67a113671..5c398b78b3c71dee788c8aae4f2f4ce826d2808f 100644 (file)
@@ -1 +1,2 @@
 DIST tpm2-tools-3.1.4.tar.gz 589388 BLAKE2B aaaa9a0158d0658dc2db4734b18ea1d49bd6c0aef84c4f1236f3134245165dccdb0bada69d92f0e5a59ecb1f2973e5cd25924d2b9c4cad2891d9e4f9fb94a84b SHA512 c5e1be4ffab305ee42a8b4a9c9aa4373158259a58844e273465f97a74f913fb12098b9fd81127148be95ecba7378f6a45b96af256dde3101a237e5e33e8e8ccb
+DIST tpm2-tools-4.1.1.tar.gz 779914 BLAKE2B 5b347b00508183cbde407e01454df0a7eb3a8080cb5b8f73d153c4972b38b98ac7c066664b54aeedef03b9bfd97b3cff482dbc44d5f11215af9c3c7754380d75 SHA512 25952cf947f0acd16b1a8dbd3ac8573bce85ff970a7e24c290c4f9cd29418e77a3e48ac82c932fbd250887a9303ab301ff92db594c2fffaba47b873382444d26
diff --git a/app-crypt/tpm2-tools/files/tpm2-tools-4.1.1-libressl.patch b/app-crypt/tpm2-tools/files/tpm2-tools-4.1.1-libressl.patch
new file mode 100644 (file)
index 0000000..2f39db3
--- /dev/null
@@ -0,0 +1,26 @@
+From a1ac2ee0c6592e6f730458c03a2abd1532c66046 Mon Sep 17 00:00:00 2001
+From: Salah Coronya <salah.coronya@gmail.com>
+Date: Sun, 12 Jan 2020 19:17:48 -0600
+Subject: [PATCH] lib/tpm2_openssl.c: Fix build for libressl
+
+Signed-off-by: Salah Coronya <salah.coronya@gmail.com>
+---
+ lib/tpm2_openssl.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/tpm2_openssl.c b/lib/tpm2_openssl.c
+index 505dd7a0..fd3861d9 100644
+--- a/lib/tpm2_openssl.c
++++ b/lib/tpm2_openssl.c
+@@ -14,7 +14,7 @@
+ #include "tpm2_openssl.h"
+ /* compatibility function for OpenSSL versions < 1.1.0 */
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
+ static int BN_bn2binpad(const BIGNUM *a, unsigned char *to, int tolen) {
+     int r;
+     int topad;
+-- 
+2.24.1
+
diff --git a/app-crypt/tpm2-tools/tpm2-tools-4.1.1.ebuild b/app-crypt/tpm2-tools/tpm2-tools-4.1.1.ebuild
new file mode 100644 (file)
index 0000000..a2ad7f1
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Tools for the TPM 2.0 TSS"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tools"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libressl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=app-crypt/tpm2-tss-2.3.1:=
+       net-misc/curl:=
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}
+       test? ( dev-util/cmocka )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+       "${FILESDIR}/${P}-libressl.patch"
+)
+
+src_configure() {
+       econf \
+               $(use_enable !libressl hardening) \
+               $(use_enable test unit)
+}