dev-python/fudge: Remove old
authorDavid Seifert <soap@gentoo.org>
Fri, 27 Dec 2019 18:52:20 +0000 (19:52 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 27 Dec 2019 18:52:20 +0000 (19:52 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/fudge/Manifest
dev-python/fudge/fudge-0.9.6-r1.ebuild [deleted file]

index 020cfd7125fa892cb18609b9d0537c20099c5fa0..75a79fdecdca3d711b83e8d2a09acc1e75fd13a3 100644 (file)
@@ -1,2 +1 @@
-DIST fudge-0.9.6.tar.gz 81653 BLAKE2B 106a0c774f9eb2f90beabfa1d84f55febaafa6c6e650b8d194464d9b7bdcf3b3ed18b943d0b7cad143f87febc75047d956d66521675c1f917f7835bf8585edd2 SHA512 69b2fa5bdd678779c0a8d9863a67e1e6724828720d2764f9f8958bc3598dcf39b22f9827efccb03014961d27d6e214c2125f639bab200b63c824c2306e3bb617
 DIST fudge-1.1.0.tar.gz 86418 BLAKE2B 3264b693bb8d4e8a0849c480b48ee79e4e99a88a819f94bfab9c098fd8ccef1171f3f0a8ca7632f29b2c22998d0847e53fcc613bbdf8ac4c1fe33aeae406997c SHA512 061d9303d28509d4e22eb2036d041359f872be85911dd85bb16e4d13bfc1cf27637f8206f215f4a37d63108ab2500d2af3f6a1a3e206fe461ead9163e0519417
diff --git a/dev-python/fudge/fudge-0.9.6-r1.ebuild b/dev-python/fudge/fudge-0.9.6-r1.ebuild
deleted file mode 100644 (file)
index 91e4234..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Replace real objects with fakes (mocks, stubs, etc) while testing"
-HOMEPAGE="http://farmdev.com/projects/fudge/ https://pypi.org/project/fudge/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
-       find -name "._*" -delete || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       nosetests -w "${BUILD_DIR}"/lib \
-               || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       distutils-r1_python_install_all
-}