fix head -1 script #28316
authorMike Frysinger <vapier@gentoo.org>
Wed, 10 Sep 2003 04:19:00 +0000 (04:19 +0000)
committerMike Frysinger <vapier@gentoo.org>
Wed, 10 Sep 2003 04:19:00 +0000 (04:19 +0000)
media-libs/libsdl/libsdl-1.2.5-r1.ebuild
media-libs/libsdl/libsdl-1.2.5-r2.ebuild
media-libs/libsdl/libsdl-1.2.6.ebuild

index 825c5706ae68d324ff6d75ae04ed4e8e05db7d09..74204bc90efcc6348729abd9c8ee913af009223c 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2003 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.5-r1.ebuild,v 1.9 2003/09/06 23:59:48 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.5-r1.ebuild,v 1.10 2003/09/10 04:19:00 vapier Exp $
 
 IUSE="arts xv opengl fbcon aalib nas esd X svga ggi alsa"
 
@@ -35,6 +35,8 @@ src_unpack() {
        cp SDL_DirectFB_video.c SDL_DirectFB_video.c.orig
        sed -e "s:DICAPS_ALL, ::" SDL_DirectFB_video.c.orig \
                > SDL_DirectFB_video.c
+       cd ${S}
+       sed -i 's:head -1:head -n 1:' configure
 }
 
 src_compile() {
index 26fefe45c3d7494a4f244837aeb3ce39ffaf894b..ba2e5416015b45541bdedebf700c13a4801ae879 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2003 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.5-r2.ebuild,v 1.7 2003/07/29 21:17:55 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.5-r2.ebuild,v 1.8 2003/09/10 04:19:00 vapier Exp $
 
 IUSE="arts xv opengl fbcon aalib nas esd X svga ggi alsa"
 
@@ -41,6 +41,7 @@ src_unpack() {
        # resolution in XFree86-4.3 instead of the worst one.
        cd ${S}
        use X && epatch ${FILESDIR}/${P}-xfree-4.3.patch.bz2
+       sed -i 's:head -1:head -n 1:' configure
 }
 
 src_compile() {
index db4cf1df72baae0e539d12d63421878dbd6c8169..68216d80ebbb1fade8ad344eeb930a0d7367194b 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2003 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.6.ebuild,v 1.1 2003/09/09 02:00:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.6.ebuild,v 1.2 2003/09/10 04:19:00 vapier Exp $
 
 DESCRIPTION="Simple Direct Media Layer"
 HOMEPAGE="http://www.libsdl.org/"
@@ -29,6 +29,8 @@ DEPEND="${RDEPEND}
 S=${WORKDIR}/SDL-${PV}
 
 src_compile() {
+       sed -i 's:head -1:head -n 1:' configure
+
        local myconf
        if use oss || use alsa || use esd || use arts || use nas ; then
                myconf="${myconf} --enable-audio"