dev-libs/openssl: Fix the build on alpha
authorMatt Turner <mattst88@gentoo.org>
Tue, 25 Feb 2020 22:37:15 +0000 (14:37 -0800)
committerMatt Turner <mattst88@gentoo.org>
Tue, 25 Feb 2020 22:40:42 +0000 (14:40 -0800)
Closes: https://bugs.gentoo.org/697840
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-libs/openssl/files/openssl-1.1.1d-config-Drop-linux-alpha-gcc-bwx.patch [new file with mode: 0644]
dev-libs/openssl/openssl-1.1.1d-r3.ebuild

diff --git a/dev-libs/openssl/files/openssl-1.1.1d-config-Drop-linux-alpha-gcc-bwx.patch b/dev-libs/openssl/files/openssl-1.1.1d-config-Drop-linux-alpha-gcc-bwx.patch
new file mode 100644 (file)
index 0000000..3771684
--- /dev/null
@@ -0,0 +1,42 @@
+From 19ded1a717b6c72c3db241f06787a353f1190755 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Tue, 18 Feb 2020 10:08:27 -0800
+Subject: [PATCH] config: Drop linux-alpha-gcc+bwx
+
+Its entry in Configuration/10-main.conf was dropped in commit
+7ead0c89185c ("Configure: fold related configurations more aggressively
+and clean-up.") probably because all but one of its bn_ops were removed
+(RC4_CHAR remained). Benchmarks on an Alpha EV7 indicate that RC4_INT is
+better than RC4_CHAR so rather than restoring the configuation, remove
+it from config.
+
+CLA: trivial
+Bug: https://bugs.gentoo.org/697840
+
+Reviewed-by: Paul Dale <paul.dale@oracle.com>
+Reviewed-by: Matt Caswell <matt@openssl.org>
+Reviewed-by: Richard Levitte <levitte@openssl.org>
+(Merged from https://github.com/openssl/openssl/pull/11130)
+---
+ config | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/config b/config
+index 2213969f90..e39481ca2a 100755
+--- a/config
++++ b/config
+@@ -498,10 +498,7 @@ case "$GUESSOS" in
+       OUT="ios64-cross" ;;
+   alpha-*-linux2)
+         ISA=`awk '/cpu model/{print$4;exit(0);}' /proc/cpuinfo`
+-      case ${ISA:-generic} in
+-      *[678]) OUT="linux-alpha+bwx-$CC" ;;
+-      *)      OUT="linux-alpha-$CC" ;;
+-      esac
++      OUT="linux-alpha-$CC"
+       if [ "$CC" = "gcc" ]; then
+           case ${ISA:-generic} in
+           EV5|EV45)           __CNF_CFLAGS="$__CNF_CFLAGS -mcpu=ev5"
+-- 
+2.24.1
+
index 8800d05fac78f5530a255617e0bd8d8bc6e83d43..97a1002fac7820ca9dfcd7ca801df529162d8d28 100644 (file)
@@ -50,6 +50,7 @@ PATCHES=(
        "${FILESDIR}"/${P}-fix-zlib.patch
        "${FILESDIR}"/${P}-fix-potential-memleaks-w-BN_to_ASN1_INTEGER.patch
        "${FILESDIR}"/${P}-reenable-the-stitched-AES-CBC-HMAC-SHA-implementations.patch
+       "${FILESDIR}"/${P}-config-Drop-linux-alpha-gcc-bwx.patch
 )
 
 S="${WORKDIR}/${MY_P}"