dev-python/jaraco-packaging: bump to 8.1.0, remove Python 2 support
authorLouis Sautier <sbraz@gentoo.org>
Fri, 28 Feb 2020 12:57:45 +0000 (13:57 +0100)
committerLouis Sautier <sbraz@gentoo.org>
Fri, 28 Feb 2020 13:09:36 +0000 (14:09 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
dev-python/jaraco-packaging/Manifest
dev-python/jaraco-packaging/jaraco-packaging-8.1.0.ebuild [new file with mode: 0644]

index fd4bde8ef6bde949a70c54e3adebe467886b6019..6a2ea2ddb81aa51947bbadf77afdb3641abb7d72 100644 (file)
@@ -2,3 +2,4 @@ DIST jaraco.packaging-4.1.tar.gz 8820 BLAKE2B 43c14e12439d161f9a42005dcaed4d6945
 DIST jaraco.packaging-5.1.tar.gz 10393 BLAKE2B ddef0ea4006b1a114d81238d5182c03cc50186452b326ef9a02f1a2e745bc731fc6969475a306b25a22d6daec5951e8d11cacd61d519e82cb461140e5003813d SHA512 d86cf6fce8037a9a5f2dfe29c7df810376127b3e02d270bfbc11e16bd43c10e0ab76f2739e5cdf904a9e54ca8d7fc3559e51d089ee39b4486c84902b23be530c
 DIST jaraco.packaging-6.1.tar.gz 14736 BLAKE2B 278ab889f236b4a53e6f3978b876952e83777da2e1c096801712bb6833fc85b342fe1c18bb7b1bd78a801c6216dbae74a75a416ef29cd4ec0a7017b8d5bd73bb SHA512 a84c71bd880879f172e6527987e9ffa681da28803112a0195fb21153cb6cd1b3d5c00a6d21c562d7c5542349f335bea4a349fd22662f22dd7bf9bef7b6b0f7d8
 DIST jaraco.packaging-6.2.tar.gz 15408 BLAKE2B 21c63b4e400bdf8b4b79873e6a96c7576b91500624c942246a8f64fc06da22e90203832c3c3084803c6ee23af8f102bb23cb12276cd3bba13446815f4a71f0dc SHA512 f8496a9dccb29dbac24927b40bc29d472b8c6bdb939bfcacf70196130ba9c961747a8b75c63574352a8bfeb2a512eb849dfba3344e942f1338ea1538e0767f33
+DIST jaraco.packaging-8.1.0.tar.gz 15322 BLAKE2B c354bec458a319bd9df0667c155203efa5c3de2d95218d0dd3a5878011d2d8fef694a490a2bac0035bff8daa18d1a3447c2c8dab7c0bd7bb09b62969f91d4709 SHA512 99996765cb047f2f0416d6afc4ff6ee0d84d03da0e07c7a7121518fbaf668f587c044f567c1d66a455372897ec1634ba5ee490552ac92064ca072e20b8f60a3b
diff --git a/dev-python/jaraco-packaging/jaraco-packaging-8.1.0.ebuild b/dev-python/jaraco-packaging/jaraco-packaging-8.1.0.ebuild
new file mode 100644 (file)
index 0000000..e6449b2
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Tools to supplement packaging Python releases"
+HOMEPAGE="https://github.com/jaraco/jaraco.packaging"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-python/importlib_metadata[${PYTHON_USEDEP}]
+       >=dev-python/namespace-jaraco-2[${PYTHON_USEDEP}]
+       >=dev-python/six-1.4[${PYTHON_USEDEP}]
+"
+DEPEND="
+       dev-python/toml[${PYTHON_USEDEP}]
+       >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+       test? (
+               ${RDEPEND}
+               >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+       )
+"
+
+distutils_enable_sphinx docs '>=dev-python/rst-linker-1.9'
+
+python_test() {
+       # Skip one test which requires network access
+       # Override pytest options to skip flake8
+       PYTHONPATH=. pytest -vv -k "not test_revived_distribution" \
+               --override-ini="addopts=--doctest-modules" \
+               || die "tests failed with ${EPYTHON}"
+}
+
+# https://wiki.gentoo.org/wiki/Project:Python/Namespace_packages#File_collisions_between_pkgutil-style_packages
+python_install() {
+       rm "${BUILD_DIR}"/lib/jaraco/__init__.py || die
+       # note: eclass may default to --skip-build in the future
+       distutils-r1_python_install --skip-build
+}