Change all instances of [ to [[.
authorChris Gianelloni <wolf31o2@gentoo.org>
Wed, 7 Mar 2007 16:00:00 +0000 (16:00 +0000)
committerChris Gianelloni <wolf31o2@gentoo.org>
Wed, 7 Mar 2007 16:00:00 +0000 (16:00 +0000)
Package-Manager: portage-2.1.2.1

games-action/d1x/ChangeLog
games-action/d1x/d1x-20040118.ebuild
games-action/d2x/ChangeLog
games-action/d2x/d2x-0.2.5-r2.ebuild
games-action/d2x/d2x-0.2.5-r3.ebuild

index 52f10f67a03a2687db09686c319dd0facd8544dd..9742bbfe51af3f34b6f06ff9842e6d82b7978577 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for games-action/d1x
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d1x/ChangeLog,v 1.7 2006/10/24 22:42:18 wolf31o2 Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/d1x/ChangeLog,v 1.8 2007/03/07 16:00:00 wolf31o2 Exp $
+
+  07 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org> d1x-20040118.ebuild:
+  Change all instances of [ to [[.
 
   24 Oct 2006; Chris Gianelloni <wolf31o2@gentoo.org> d1x-20040118.ebuild:
   Moved cdrom_get_cds to src_unpack since binary packages don't require the
index ad715b098421a845a13163bd63403bd6f7522142..ffb432fb225316afa49526cfd05c2b359133b12d 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d1x/d1x-20040118.ebuild,v 1.7 2006/10/24 22:42:18 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d1x/d1x-20040118.ebuild,v 1.8 2007/03/07 16:00:00 wolf31o2 Exp $
 
 inherit eutils games
 
@@ -71,7 +71,7 @@ src_unpack() {
 
        cat > "${T}"/d1x <<-EOS
        #!/bin/sh
-       if [ ! -e "\${HOME}/.d1x" ]; then
+       if [[ ! -e "\${HOME}/.d1x" ]] ; then
          mkdir "\${HOME}/.d1x"
          cp "${GAMES_DATADIR}/d1x/d1x.ini" "\${HOME}/.d1x/"
        fi
index a5f22ab94122d2c4eb05b10117468e17418ba74a..7843f4d09d268909a278bfcbf5ab3e337df07add 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for games-action/d2x
 # Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/ChangeLog,v 1.17 2007/01/09 21:54:12 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/ChangeLog,v 1.18 2007/03/07 15:55:40 wolf31o2 Exp $
+
+  07 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org> d2x-0.2.5-r2.ebuild,
+  d2x-0.2.5-r3.ebuild:
+  Change all instances of [ to [[.
 
 *d2x-0.2.5-r3 (09 Jan 2007)
 
index 72b02560c14f3f1f09b6a0453567f6c9b1b3faf3..8fd558451978d6470215e615a68889372cbd7cb7 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r2.ebuild,v 1.5 2006/10/24 22:31:42 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r2.ebuild,v 1.6 2007/03/07 15:55:40 wolf31o2 Exp $
 
 inherit flag-o-matic eutils games
 
@@ -29,7 +29,7 @@ src_unpack() {
        if use cdinstall ; then
                if [[ ! -e "${DISTDIR}"/descent2.sow ]] ; then
                        cdrom_get_cds d2data
-                       if [ -e ${CDROM_ROOT}/d2data/descent2.sow ] ; then
+                       if [[ -e ${CDROM_ROOT}/d2data/descent2.sow ]] ; then
                                export CDROM_ROOT=${CDROM_ROOT}/d2data
                                einfo "Found the original Descent2 CD"
                                einfo "Copying descent2.sow to ${DISTDIR}"
@@ -62,17 +62,17 @@ src_compile() {
        for ren in sdl $(useq opengl && echo opengl) \
                        $(useq svga && echo svga) $(useq ggi && echo ggi)
        do
-               [ "${ren}" == "sdl" ] \
+               [[ "${ren}" == "sdl" ]] \
                        && renconf="" \
                        || renconf="--with-${ren}"
-               [ "${ren}" == "svga" ] \
+               [[ "${ren}" == "svga" ]] \
                        && defflags="-DSVGALIB_INPUT" \
                        || defflags=""
                make distclean
                egamesconf \
                        ${myconf} \
                        ${renconf} \
-                       --datadir=${GAMES_DATADIR_BASE} \
+                       --datadir="${GAMES_DATADIR_BASE}" \
                        || die "conf ${ren}"
                emake CXXFLAGS="${CXXFLAGS} ${defflags}" || die "build ${ren}"
                mv d2x* my-bins/
index e66bb40d5fe53623054eaa26ea4c976326b67735..79430b5b39aa14f351f39f611e5368bf9fd289a9 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r3.ebuild,v 1.1 2007/01/09 21:54:12 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r3.ebuild,v 1.2 2007/03/07 15:55:40 wolf31o2 Exp $
 
 inherit eutils flag-o-matic games
 
@@ -48,10 +48,10 @@ src_compile() {
        mkdir my-bins
        for ren in sdl $(useq opengl && echo opengl) \
                        $(useq svga && echo svga) $(useq ggi && echo ggi) ; do
-               [ "${ren}" == "sdl" ] \
+               [[ "${ren}" == "sdl" ]] \
                        && renconf="" \
                        || renconf="--with-${ren}"
-               [ "${ren}" == "svga" ] \
+               [[ "${ren}" == "svga" ]] \
                        && defflags="-DSVGALIB_INPUT" \
                        || defflags=""
                make distclean