Enable globstar shell option by default in EAPI="4-python".
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Sat, 5 May 2012 16:00:57 +0000 (18:00 +0200)
committerArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Sat, 5 May 2012 16:00:57 +0000 (18:00 +0200)
bin/ebuild.sh
doc/package/ebuild/eapi/4-python.docbook

index 173865cde219682dd6f3d39c41ccf49b60c314c0..32dc64f0c6f4fe79fcefbd1406c250c4e2dde6a2 100755 (executable)
@@ -512,6 +512,10 @@ if ! has "$EBUILD_PHASE" clean cleanrm depend && \
        [[ -n $EAPI ]] || EAPI=0
 fi
 
+if has "${EAPI:-0}" 4-python; then
+       shopt -s globstar
+fi
+
 if ! has "$EBUILD_PHASE" clean cleanrm ; then
        if [[ $EBUILD_PHASE = depend || ! -f $T/environment || \
                -f $PORTAGE_BUILDDIR/.ebuild_changed ]] || \
index b4cbc1ad480aa39e4842310ef6eb63f5faffcef4..99ad197aca618e256e4ce0d99549f61335b2a35e 100644 (file)
@@ -31,6 +31,12 @@ official EAPI 4-python Specification</ulink>.
 The "." character is allowed in USE flags.
 </para>
 </section>
+<section id='package-ebuild-eapi-4-python-globstar'>
+<title>globstar shell option enabled by default</title>
+<para>
+globstar shell option is enabled by default, which enables recursive expansion of ** pattern in pathname expansion context.
+</para>
+</section>
 <section id='package-ebuild-eapi-4-python-repository-variable'>
 <title>REPOSITORY Variable</title>
 <para>