gui-apps/swaybg: initial add
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 30 Apr 2019 03:28:47 +0000 (22:28 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 30 Apr 2019 03:34:56 +0000 (22:34 -0500)
Bug: https://bugs.gentoo.org/684622
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
gui-apps/swaybg/metadata.xml [new file with mode: 0644]
gui-apps/swaybg/swaybg-9999.ebuild [new file with mode: 0644]

diff --git a/gui-apps/swaybg/metadata.xml b/gui-apps/swaybg/metadata.xml
new file mode 100644 (file)
index 0000000..4708ce6
--- /dev/null
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>prometheanfire@gentoo.org</email>
+               <name>Matthew Thode</name>
+       </maintainer>
+       <maintainer type="person">
+               <email>speedjack95@gmail.com</email>
+               <name>Niccolò Scatena</name>
+       </maintainer>
+       <longdescription lang="en">
+               Sway's wallpaper utility, compatible with any Wayland compositor
+               which implements the wlr-layer-shell, xdg-output and xdg-shell protocols.
+       </longdescription>
+       <use>
+               <flag name="man">Build and install man pages</flag>
+       </use>
+       <upstream>
+               <remote-id type="github">swaywm/swaybg</remote-id>
+               <maintainer status="active">
+                       <email>sir@cmpwn.com</email>
+                       <name>Drew DeVault</name>
+               </maintainer>
+               <bugs-to>https://github.com/swaywm/swaybg/issues</bugs-to>
+               <changelog>https://github.com/swaywm/swaybg/releases</changelog>
+       </upstream>
+</pkgmetadata>
diff --git a/gui-apps/swaybg/swaybg-9999.ebuild b/gui-apps/swaybg/swaybg-9999.ebuild
new file mode 100644 (file)
index 0000000..79643a5
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A wallpaper utility for Wayland"
+HOMEPAGE="https://github.com/swaywm/swaybg"
+
+if [[ ${PV} == 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+       SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+DEPEND="
+       dev-libs/wayland
+"
+RDEPEND="
+       ${DEPEND}
+       !<=gui-wm/sway-1.1
+"
+BDEPEND="
+       >=dev-libs/wayland-protocols-1.14
+       x11-libs/gdk-pixbuf
+       x11-libs/cairo
+       virtual/pkgconfig
+       man? ( app-text/scdoc )
+"
+
+src_configure() {
+       local emesonargs=(
+               -Dman-pages=$(usex man enabled disabled)
+               "-Dwerror=false"
+       )
+
+       meson_src_configure
+}