dev-ros/qt_gui: require qt5, not 4
authorAlexis Ballier <aballier@gentoo.org>
Tue, 28 Feb 2017 07:42:03 +0000 (08:42 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 28 Feb 2017 11:26:46 +0000 (12:26 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ros/qt_gui/qt_gui-0.3.4-r1.ebuild [new file with mode: 0644]
dev-ros/qt_gui/qt_gui-9999.ebuild

diff --git a/dev-ros/qt_gui/qt_gui-0.3.4-r1.ebuild b/dev-ros/qt_gui/qt_gui-0.3.4-r1.ebuild
new file mode 100644 (file)
index 0000000..e5f5859
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-qt/qtcore:5
+       dev-python/rospkg[${PYTHON_USEDEP}]
+       >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
index f5ef4e6552db54277a4609786e3f0fed8ef18bec..e5f5859d5d201c6b71bd9f64e8006fca35fbe1d6 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -17,7 +17,7 @@ SLOT="0"
 IUSE=""
 
 RDEPEND="
-       dev-qt/qtcore:4
+       dev-qt/qtcore:5
        dev-python/rospkg[${PYTHON_USEDEP}]
        >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
 "