Version bump, security bugs
authorSteve Dibb <beandog@gentoo.org>
Fri, 2 Mar 2007 22:49:37 +0000 (22:49 +0000)
committerSteve Dibb <beandog@gentoo.org>
Fri, 2 Mar 2007 22:49:37 +0000 (22:49 +0000)
Package-Manager: portage-2.1.1-r2

www-apps/wordpress/ChangeLog
www-apps/wordpress/files/digest-wordpress-2.1.2 [new file with mode: 0644]
www-apps/wordpress/wordpress-2.1.2.ebuild [new file with mode: 0644]

index d3807981db855b46f9cd518f5148dbd298faa44e..2865425ce2114b31199ba1193a99c59c070716bc 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for www-apps/wordpress
 # Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/wordpress/ChangeLog,v 1.79 2007/02/28 15:32:30 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/wordpress/ChangeLog,v 1.80 2007/03/02 22:49:37 beandog Exp $
+
+*wordpress-2.1.2 (02 Mar 2007)
+
+  02 Mar 2007; Steve Dibb <beandog@gentoo.org> -wordpress-2.1.1.ebuild,
+  +wordpress-2.1.2.ebuild:
+  Version bump, security bugs
 
   28 Feb 2007; Steve Dibb <beandog@gentoo.org> wordpress-2.0.9.ebuild:
   Reverting to unstable, security bugs 163817, 168449, 168529
diff --git a/www-apps/wordpress/files/digest-wordpress-2.1.2 b/www-apps/wordpress/files/digest-wordpress-2.1.2
new file mode 100644 (file)
index 0000000..fcd611d
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 b1ae0c152e60300cba8c40c030baafd4 wordpress-2.1.2.tar.gz 694915
+RMD160 a081024defa6e6738f4932531bdf1ead0a3767a4 wordpress-2.1.2.tar.gz 694915
+SHA256 6888bd162e692666dcbd09ef8ca1e9dc970359e647b952782d3344d2813ff532 wordpress-2.1.2.tar.gz 694915
diff --git a/www-apps/wordpress/wordpress-2.1.2.ebuild b/www-apps/wordpress/wordpress-2.1.2.ebuild
new file mode 100644 (file)
index 0000000..6114776
--- /dev/null
@@ -0,0 +1,89 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/wordpress/wordpress-2.1.2.ebuild,v 1.1 2007/03/02 22:49:37 beandog Exp $
+
+inherit webapp eutils depend.php
+
+DESCRIPTION="Wordpress php and mysql based CMS system."
+HOMEPAGE="http://wordpress.org/"
+SRC_URI="http://www.wordpress.org/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+need_php
+
+pkg_setup() {
+       webapp_pkg_setup
+
+       require_php_with_any_use mysql mysqli
+       require_php_with_use pcre
+}
+
+src_install() {
+       local docs="license.txt readme.html"
+
+       webapp_src_preinst
+
+       einfo "Installing main files"
+       cp wp-config-sample.php wp-config.php
+       cp -r * ${D}${MY_HTDOCSDIR}
+       einfo "Done"
+
+       ewarn
+       ewarn Please make sure you have register_globals = off set in your /etc/apache2/php.ini file
+       ewarn If this is not an option for your web server and you NEED it set to on, then insert the following in your WordPress .htaccess file:
+       ewarn php_flag register_globals off
+       ewarn
+
+       ewarn
+       ewarn You will need to create a table for your WordPress database.  This
+       ewarn assumes you have some knowledge of MySQL, and already have it
+       ewarn installed and configured.  If not, please refer to
+       ewarn the Gentoo MySQL guide at the following URL:
+       ewarn http://www.gentoo.org/doc/en/mysql-howto.xml
+       ewarn Log in to MySQL, and create a new database called
+       ewarn "wordpress". From this point, you will need to edit
+       ewarn your wp-config.php file in $DocumentRoot/wordpress/
+       ewarn and point to your database. Once this is done, you can log in to
+       ewarn WordPress at http://localhost/wordpress
+       ewarn
+
+       ewarn
+       ewarn If you are upgrading from a previous version BACK UP your
+       ewarn database.  Once you are done with that, browse to
+       ewarn http://localhost/wordpress/wp-admin/upgrade.php and follow
+       ewarn the instructions on the screen.
+       ewarn
+
+       # handle documentation files
+       #
+       # NOTE that doc files go into /usr/share/doc as normal; they do NOT
+       # get installed per vhost!
+
+       dodoc ${docs}
+       for doc in ${docs} INSTALL; do
+               rm -f ${doc}
+       done
+
+       # Identify the configuration files that this app uses
+       # User can want to make changes to these!
+       webapp_serverowned ${MY_HTDOCSDIR}/index.php
+       #webapp_serverowned ${MY_HTDOCSDIR}/wp-layout.css
+       webapp_serverowned ${MY_HTDOCSDIR}/wp-admin/menu.php
+       webapp_serverowned ${MY_HTDOCSDIR}
+       webapp_configfile  ${MY_HTDOCSDIR}/wp-config.php
+       # Identify any script files that need #! headers adding to run under
+       # a CGI script (such as PHP/CGI)
+       #
+       # for wordpress, we *assume* that all .php files need to have CGI/BIN
+       # support added
+
+       # post-install instructions
+       #webapp_postinst_txt en ${FILESDIR}/1.2/postinstall-en.txt
+
+       # now strut stuff
+       webapp_src_install
+}