GCC 4.1 cleanup wrt bug #147240
authorMarkus Ullmann <jokey@gentoo.org>
Sun, 8 Oct 2006 11:15:12 +0000 (11:15 +0000)
committerMarkus Ullmann <jokey@gentoo.org>
Sun, 8 Oct 2006 11:15:12 +0000 (11:15 +0000)
Package-Manager: portage-2.1.2_pre2-r6

app-misc/rioutil/ChangeLog
app-misc/rioutil/files/digest-rioutil-1.4.4
app-misc/rioutil/files/digest-rioutil-1.5.0 [new file with mode: 0644]
app-misc/rioutil/files/rioutil-gcc4.1.1.patch [new file with mode: 0644]
app-misc/rioutil/rioutil-1.4.4.ebuild
app-misc/rioutil/rioutil-1.5.0.ebuild [new file with mode: 0644]

index 5b8f831c668ac95392d530f09285c3344678e183..31877c6c66b81ee719468b180ce28fcfd24d1cc9 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for app-misc/rioutil
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/rioutil/ChangeLog,v 1.22 2005/07/21 17:25:30 dholm Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rioutil/ChangeLog,v 1.23 2006/10/08 11:15:11 jokey Exp $
+
+*rioutil-1.5.0 (08 Oct 2006)
+
+  08 Oct 2006; Markus Ullmann <jokey@gentoo.org>
+  -files/rioutil-1.5.0b-time.patch, +files/rioutil-gcc4.1.1.patch,
+  rioutil-1.4.4.ebuild, -rioutil-1.4.7.ebuild, +rioutil-1.5.0.ebuild,
+  -rioutil-1.5.0b.ebuild:
+  GCC 4.1 cleanup wrt bug #147240
 
   21 Jul 2005; David Holm <dholm@gentoo.org> rioutil-1.5.0b.ebuild:
   Added to ~ppc.
index ecc62032bbc575821fc7ca7bd4f79a355a195c0f..360ab1ed20d42476d0db8e663775bfc8a4bd0eb4 100644 (file)
@@ -1 +1,3 @@
 MD5 926eda6ef95a4b2a9a9b4ba1dc52c3d9 rioutil-1.4.4.tar.bz2 278386
+RMD160 bd78dce4009983b2d9845321f705c2d42fa2236e rioutil-1.4.4.tar.bz2 278386
+SHA256 16241d018370fa188cf8e3d4c949d65af5f73d22ffc1137e1add6335039a8b3f rioutil-1.4.4.tar.bz2 278386
diff --git a/app-misc/rioutil/files/digest-rioutil-1.5.0 b/app-misc/rioutil/files/digest-rioutil-1.5.0
new file mode 100644 (file)
index 0000000..5c564a6
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 0663d52c97fb20dfc93185ac805e5048 rioutil-1.5.0.tar.gz 401244
+RMD160 2f1db9eb36501aecdb388278d5f7c1876bfebf19 rioutil-1.5.0.tar.gz 401244
+SHA256 4991cda30bcd0cd01097c4d220c5facf67e988d4bbfc2f272a359ac89d52e9a7 rioutil-1.5.0.tar.gz 401244
diff --git a/app-misc/rioutil/files/rioutil-gcc4.1.1.patch b/app-misc/rioutil/files/rioutil-gcc4.1.1.patch
new file mode 100644 (file)
index 0000000..d940bdb
--- /dev/null
@@ -0,0 +1,11 @@
+--- rioutil-1.4.4.orig/librioutil/rio.c
++++ rioutil-1.4.4/librioutil/rio.c
+@@ -373,7 +373,7 @@
+     return ret;
+   }
+
+-  iptr = (u_int32_t *)read_buffer = (u_int8_t *) malloc (RIO_FTS);
++  iptr = (u_int32_t *)(read_buffer = (u_int8_t *) malloc (RIO_FTS));
+   if (read_buffer == NULL) {
+     rio_log (rio, errno, "Could not allocate read buffer\n");
+     return errno;
index 8f0f28d02d166afe2dfcf7a4099405da5da48a94..43b6e5bc9b0c1255cfbc87c5ab2e4a1b3dd16c7d 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/rioutil/rioutil-1.4.4.ebuild,v 1.11 2005/04/22 09:03:10 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rioutil/rioutil-1.4.4.ebuild,v 1.12 2006/10/08 11:15:11 jokey Exp $
 
 inherit eutils
 
@@ -18,17 +18,18 @@ DEPEND="sys-libs/zlib
        dev-libs/libusb"
 
 src_unpack() {
-       unpack ${A} || die 'Failed to unpack!'
+       unpack ${A}
        cd "${S}"
        epatch "${FILESDIR}/${P}-26headers.patch"
+       epatch "${FILESDIR}/${PN}-gcc4.1.1.patch"
 }
 
 src_compile() {
-       econf --with-usbdevfs || die
-       emake || die "emake failure"
+       econf --with-usbdevfs || die "econf failed"
+       emake || die "emake failed"
 }
 
 src_install() {
        einstall || die
-       dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+       dodoc AUTHORS ChangeLog NEWS README TODO
 }
diff --git a/app-misc/rioutil/rioutil-1.5.0.ebuild b/app-misc/rioutil/rioutil-1.5.0.ebuild
new file mode 100644 (file)
index 0000000..8ee4610
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rioutil/rioutil-1.5.0.ebuild,v 1.1 2006/10/08 11:15:11 jokey Exp $
+
+inherit eutils
+
+DESCRIPTION="Command line tool for transfering mp3s to and from a Rio 600, 800, Rio Riot, and Nike PSA/Play"
+HOMEPAGE="http://rioutil.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rioutil/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/zlib
+       virtual/libc
+       dev-libs/libusb"
+
+src_install() {
+       emake DESTDIR=${D} install || die
+       dodoc AUTHORS ChangeLog NEWS README TODO
+}