sys-devel/bison: Bump to version 3.5.2
authorLars Wendler <polynomial-c@gentoo.org>
Fri, 14 Feb 2020 07:51:00 +0000 (08:51 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Fri, 14 Feb 2020 07:52:14 +0000 (08:52 +0100)
Package-Manager: Portage-2.3.88, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-devel/bison/Manifest
sys-devel/bison/bison-3.5.2.ebuild [new file with mode: 0644]

index 9d3a4c07277d5f7aeda952104fac97039e8267ca..46e62f0473d8d64efd993e86de9c5906e496f30e 100644 (file)
@@ -7,4 +7,5 @@ DIST bison-3.4.2.tar.xz 2240532 BLAKE2B fb3d90dc3f21075069684e5d9f8d6982353d909b
 DIST bison-3.5-patches-01.tar.xz 9220 BLAKE2B 41ccdc164960e56722143b579a679a2699905c2ee2779fc882bb56871aa0a1d0fb530cf8249c354375bc2d61285754b257262191446524c8ec5b0cff0cd973ec SHA512 28b108540cad75dd6aec9cd0a17320a44e7bcd305faea9d35f5b38b0672a3646cacce3c45f5c1528560081280ed617f98fa467ad2479e0df108e0020ba029180
 DIST bison-3.5.1-patches-01.tar.xz 9388 BLAKE2B 656cdc4fef308df3bc97c8f452ae75440909ed7eae13a8bdfc6b3b380f9d392ac3c9d300cb1e7a6d5548271b6ac63f5dfef594cbf9ef5322f97024468ed8e757 SHA512 195725726575998ff3d274d723ce3f605f9e1478601904668f165c1d9f628ed94380dfa65e546f12e3fc80b41aae7899774208510f382864dffde8545710f211
 DIST bison-3.5.1.tar.xz 2354592 BLAKE2B 29e85c8f38f122b90ca38d4def3c9305a562dc29755865fc091f809191c0af435fe8fb5b424da8b69f143f30d8b6439876f735bf45dd8cf9f45e291e93789078 SHA512 f5a075608c563652181e6804cdd280761a05b88f41f4b287d49bbe4c18b08724b057ff95c07dfa3fddb5c95de8b229db76821e9d197d4bec206102f62cb390d8
+DIST bison-3.5.2.tar.xz 2362956 BLAKE2B f2c487cff816c010e82e95c23c26323eb4e11c7293a1358359564068b84438edded20586b4729e1432a7718f9ba6a9856298d66c17e45a10d28216272be6eea8 SHA512 f8d213fa58f04ce8e55437ecfa378869a85c07234223dc89dbe7533b7f663a105eddaebd0902fb46b258048400c09d4b8181f033932b74aa41bca13ea5c120aa
 DIST bison-3.5.tar.xz 2341024 BLAKE2B 1c0af1cc12cd1e4d264adebb5c043b8ac510cd613a2a22c4232d88b077eecac7d1a36c07a4fb3d425cd1907b830f53862be570bbca6faaf0ef43981d6fecd1d3 SHA512 309ba77cfbf5d5ca697f522ac18ca9b55a1ec4e690b87220c97ffb1137b8bd8b22aa14c111166f0f4bf001e88f4bcbfd0583bc09810c246f0dc60fd6e8478950
diff --git a/sys-devel/bison/bison-3.5.2.ebuild b/sys-devel/bison/bison-3.5.2.ebuild
new file mode 100644 (file)
index 0000000..60e7b20
--- /dev/null
@@ -0,0 +1,93 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+PATCHES="${PN}-3.5.1-patches-01.tar.xz"
+
+DESCRIPTION="A general-purpose (yacc-compatible) parser generator"
+HOMEPAGE="https://www.gnu.org/software/bison/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+       mirror://gentoo/${PATCHES}
+       https://dev.gentoo.org/~whissi/dist/bison/${PATCHES}
+       https://dev.gentoo.org/~polynomial-c/dist/bison/${PATCHES}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples nls static test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=sys-devel/m4-1.4.16"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       sys-devel/flex
+       examples? ( dev-lang/perl )
+       nls? ( sys-devel/gettext )
+       test? ( dev-lang/perl )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO ) # ChangeLog-2012 ChangeLog-1998 PACKAGING README-alpha README-release
+
+PATCHES=(
+       "${WORKDIR}"/patches/${PN}-3.5-optional-perl.patch #538300
+       "${WORKDIR}"/patches/${PN}-3.5.1-avoid_autoreconf.patch
+)
+
+src_prepare() {
+       # Record date to avoid 'config.status --recheck' & regen of 'tests/package.m4'
+       touch -r configure.ac old.configure.ac || die
+       touch -r configure old.configure || die
+
+       default
+
+       # Restore date after patching
+       touch -r old.configure.ac configure.ac || die
+       touch -r old.configure configure || die
+
+       # The makefiles make the man page depend on the configure script
+       # which we patched above.  Touch it to prevent regeneration.
+       touch doc/bison.1 || die #548778 #538300#9
+
+       # Avoid regenerating the info page when the timezone is diff. #574492
+       sed -i '2iexport TZ=UTC' build-aux/mdate-sh || die
+}
+
+src_configure() {
+       use static && append-ldflags -static
+
+       local myeconfargs=(
+               --docdir='$(datarootdir)'/doc/${PF}
+               $(use_enable examples)
+               $(use_enable nls)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_install() {
+       default
+
+       # This one is installed by dev-util/yacc
+       mv "${ED}"/usr/bin/yacc{,.bison} || die
+       mv "${ED}"/usr/share/man/man1/yacc{,.bison}.1 || die
+
+       # We do not need liby.a
+       rm -r "${ED}"/usr/lib* || die
+}
+
+pkg_postinst() {
+       local f="${EROOT}/usr/bin/yacc"
+       if [[ ! -e ${f} ]] ; then
+               ln -s yacc.bison "${f}"
+       fi
+}
+
+pkg_postrm() {
+       # clean up the dead symlink when we get unmerged #377469
+       local f="${EROOT}/usr/bin/yacc"
+       if [[ -L ${f} && ! -e ${f} ]] ; then
+               rm -f "${f}"
+       fi
+}