net-p2p/syncthing: work around ppc64 test failure
authorMarek Szuba <marecki@gentoo.org>
Fri, 17 Apr 2020 17:50:19 +0000 (18:50 +0100)
committerMarek Szuba <marecki@gentoo.org>
Fri, 17 Apr 2020 17:57:29 +0000 (18:57 +0100)
For some reason one of the Syncthing tests - TestIssue5063 - times out
on our ppc64 buildhost, with 100% reproducibility. Upstream were not
aware of the problem because apparently they have never run the test
suite on such a system, that said their suggestion to adjust the
time-out threshold appears to do the trick. Make it 20 s i.e. twice what
it originally is, hopefully this will prevent the problem from
resurfacing any time soon.

Closes: https://bugs.gentoo.org/717108
See-also: https://github.com/syncthing/syncthing/issues/6539
Signed-off-by: Marek Szuba <marecki@gentoo.org>
net-p2p/syncthing/files/syncthing-1.3.4-TestIssue5063_timeout.patch [new file with mode: 0644]
net-p2p/syncthing/syncthing-1.3.4-r1.ebuild
net-p2p/syncthing/syncthing-1.4.2.ebuild

diff --git a/net-p2p/syncthing/files/syncthing-1.3.4-TestIssue5063_timeout.patch b/net-p2p/syncthing/files/syncthing-1.3.4-TestIssue5063_timeout.patch
new file mode 100644 (file)
index 0000000..3148dc8
--- /dev/null
@@ -0,0 +1,18 @@
+As of early April 2020, running the Syncthing test suite on the Gentoo ppc64
+buildhost fails due to TestIssue5063 timing out. Increase the time-out
+threshold for this test to allow it to pass.
+
+Other arches we currently support (i.e. amd64, arm and x86) shouldn't be
+affected by the change because thay have always passed so far anyway.
+
+--- a/lib/model/model_test.go
++++ b/lib/model/model_test.go
+@@ -914,7 +914,7 @@
+       }()
+       select {
+       case <-finished:
+-      case <-time.After(10 * time.Second):
++      case <-time.After(20 * time.Second):
+               pprof.Lookup("goroutine").WriteTo(os.Stdout, 1)
+               t.Fatal("Timed out before all devices were added")
+       }
index 57a69fe4269c1130585835da3a4adf9ea22c9169..8027187afc57c777acf12b415ad5cbe613ace009 100644 (file)
@@ -292,6 +292,10 @@ RDEPEND="acct-group/syncthing
 
 DOCS=( README.md AUTHORS CONTRIBUTING.md )
 
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.3.4-TestIssue5063_timeout.patch
+)
+
 src_prepare() {
        # Bug #679280
        xdg_environment_reset
index 7b3436014f4dc503d3428b45d6fabb8e0668a7e9..5047b42159ab0bd69ed9c02de6c3841999096ef9 100644 (file)
@@ -306,6 +306,10 @@ RDEPEND="acct-group/syncthing
 
 DOCS=( README.md AUTHORS CONTRIBUTING.md )
 
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.3.4-TestIssue5063_timeout.patch
+)
+
 src_prepare() {
        # Bug #679280
        xdg_environment_reset