sys-apps/bubblewrap-0.4.1: bump
authorPiotr Karbowski <slashbeast@gentoo.org>
Fri, 1 May 2020 21:28:21 +0000 (23:28 +0200)
committerPiotr Karbowski <slashbeast@gentoo.org>
Fri, 1 May 2020 21:29:51 +0000 (23:29 +0200)
- updated github URL to the new one.
- Joining as maintainer

Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
sys-apps/bubblewrap/Manifest
sys-apps/bubblewrap/bubblewrap-0.4.1.ebuild [new file with mode: 0644]
sys-apps/bubblewrap/metadata.xml

index 5ae1117bc2e4b6ecdfa6628bd4d884f3839abac1..3d92b6d655bdf5284e5dcbc75b77c454469fdebf 100644 (file)
@@ -1 +1,2 @@
 DIST bubblewrap-0.3.1.tar.xz 209924 BLAKE2B bacc4080106cd9876bf0e1ad866a7397d7d232e61a720b52b5a6b9b0d860e625511ed15ac630aa71003fb9fa145ffa9d08ae2e6ba6d1411fd75e7d9568312717 SHA512 74e36caa56540a956158445f5f38c7ac5f7ff3c733ecaf85893de4607900e1fe4050db86a4435cbe18d722e90c5b39c466c555ea8ea8d4944da6207ef1011d67
+DIST bubblewrap-0.4.1.tar.xz 214496 BLAKE2B bdbff50cc4e28c91d83c814df7f2ee15702962d26a9316bd841b1e63bf5976c4549c88e20869e8cc236a8a0c9a065518f945c356fa7a058f8831f5b1e9d4eb0d SHA512 0ff46dc0fda2d0cffbb36cc52ff43951b30cbd835a42cc56806acbbbd827796bfadbb1cfafc84d6b47a72c031ca44abe1c377acc0cc25fe3b33e854f5f687d35
diff --git a/sys-apps/bubblewrap/bubblewrap-0.4.1.ebuild b/sys-apps/bubblewrap/bubblewrap-0.4.1.ebuild
new file mode 100644 (file)
index 0000000..7090c2e
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 linux-info
+
+DESCRIPTION="Unprivileged sandboxing tool, namespaces-powered chroot-like solution"
+HOMEPAGE="https://github.com/containers/bubblewrap/"
+SRC_URI="https://github.com/containers/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="selinux +suid"
+
+RDEPEND="
+       sys-libs/libseccomp
+       sys-libs/libcap
+       selinux? ( >=sys-libs/libselinux-2.1.9 )
+"
+DEPEND="${RDEPEND}
+       app-text/docbook-xml-dtd:4.3
+       app-text/docbook-xsl-stylesheets
+       dev-libs/libxslt
+       virtual/pkgconfig
+"
+
+# tests require root priviledge
+RESTRICT="test"
+PATCHES=(
+       "${FILESDIR}/bubblewrap-0.3.1-selinux-configure.patch" # bug 674312
+)
+
+pkg_setup() {
+       if [[ ${MERGE_TYPE} != buildonly ]]; then
+               CONFIG_CHECK="~UTS_NS ~IPC_NS ~USER_NS ~PID_NS ~NET_NS"
+               linux-info_pkg_setup
+       fi
+}
+
+src_configure() {
+       econf \
+               $(use_enable selinux) \
+               "--enable-man" \
+               "--with-bash-completion-dir=$(get_bashcompdir)" \
+               "--with-priv-mode=$(usex suid setuid none)"
+}
index 29a569e6d4111ef2ab32b8bc875230f1b03dfc24..ffd5ca6e2a5aecd2fbf611b6726967567d3842c5 100644 (file)
@@ -1,11 +1,15 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
+       <maintainer type="person">
+               <email>slashbeast@gentoo.org</email>
+               <name>Piotr Karbowski</name>
+       </maintainer>
        <maintainer type="project">
                <email>gnome@gentoo.org</email>
                <name>Gentoo GNOME Desktop</name>
        </maintainer>
        <upstream>
-               <remote-id type="github">projectatomic/bubblewrap</remote-id>
+               <remote-id type="github">containers/bubblewrap</remote-id>
        </upstream>
 </pkgmetadata>