dev-libs/elfutils: bump up to 0.179
authorSergei Trofimovich <slyfox@gentoo.org>
Mon, 30 Mar 2020 23:09:24 +0000 (00:09 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Mon, 30 Mar 2020 23:09:24 +0000 (00:09 +0100)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-libs/elfutils/Manifest
dev-libs/elfutils/elfutils-0.179.ebuild [new file with mode: 0644]
dev-libs/elfutils/files/elfutils-0.179-PaX-support.patch [new file with mode: 0644]

index d86f09cabcff35a6908577e5d8bcf5ed159b5199..eb04759218f7f510b199a5efcc89e28d601e6961 100644 (file)
@@ -1,2 +1,3 @@
 DIST elfutils-0.177.tar.bz2 8852413 BLAKE2B 03f432342651f7646d73b7847325bd14b722ce34d85df01b1ad072b916af9b9da2d0d119cd24e952073bd584ec76b027ba9b6c7d45fb057372b3e700b1f5741a SHA512 2779987463a22ed220759e25a09c9a1eb84c0f36db37675136e59aa55c7f8f90b7a7d34ffc4e6a4291d7fa73692a1bd1a303a74270b11d1623b4f9868d19498f
 DIST elfutils-0.178.tar.bz2 9007557 BLAKE2B 241b611dbfac37f35a670fbe80096c21b870e4b26fcddc8af26fba0373c9cd72eae42aabae2803b7b16c3bf649aeda036b1ea1b40952b43c4021ed23fcb51e80 SHA512 356656ad0db8f6877b461de1a11280de16a9cc5d8dde4381a938a212e828e32755135e5e3171d311c4c9297b728fbd98123048e2e8fbf7fe7de68976a2daabe5
+DIST elfutils-0.179.tar.bz2 9057637 BLAKE2B b34f5af6d2a6613622f4d5da78b9ae10e60800fc91cb4607115fcaaf90c1c544460fb02e164f87e52951a446d6479909bbf3aa02b7db78b26af7863290de8848 SHA512 ff2d96ad1db08e3a2ddaa60bd5a05e9b61ffa71d646f889cebb6bef51322e874930809c6dd0a257ced8c6e8de4b59ecf13ca6741dc68f9400293208278a0c052
diff --git a/dev-libs/elfutils/elfutils-0.179.ebuild b/dev-libs/elfutils/elfutils-0.179.ebuild
new file mode 100644 (file)
index 0000000..bf24e85
--- /dev/null
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic multilib-minimal
+
+DESCRIPTION="Libraries/utilities to handle ELF objects (drop in replacement for libelf)"
+HOMEPAGE="http://elfutils.org/"
+SRC_URI="https://sourceware.org/elfutils/ftp/${PV}/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2+ LGPL-3+ ) utils? ( GPL-3+ )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 lzma nls static-libs test +threads +utils valgrind"
+
+RDEPEND=">=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+       bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
+       lzma? ( >=app-arch/xz-utils-5.0.5-r1[${MULTILIB_USEDEP}] )
+       !dev-libs/libelf"
+DEPEND="${RDEPEND}
+       valgrind? ( dev-util/valgrind )
+"
+BDEPEND="nls? ( sys-devel/gettext )
+       >=sys-devel/flex-2.5.4a
+       sys-devel/m4"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-0.175-disable-biarch-test-PR24158.patch
+       "${FILESDIR}"/${PN}-0.177-disable-large.patch
+       "${FILESDIR}"/${PN}-0.179-PaX-support.patch
+)
+
+src_prepare() {
+       default
+
+       if ! use static-libs; then
+               sed -i -e '/^lib_LIBRARIES/s:=.*:=:' -e '/^%.os/s:%.o$::' lib{asm,dw,elf}/Makefile.in || die
+       fi
+       # https://sourceware.org/PR23914
+       sed -i 's:-Werror::' */Makefile.in || die
+}
+
+src_configure() {
+       use test && append-flags -g #407135
+       multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+       ECONF_SOURCE="${S}" econf \
+               $(use_enable nls) \
+               $(use_enable threads thread-safety) \
+               $(use_enable valgrind) \
+               --disable-debuginfod \
+               --program-prefix="eu-" \
+               --with-zlib \
+               $(use_with bzip2 bzlib) \
+               $(use_with lzma)
+}
+
+multilib_src_test() {
+       env     LD_LIBRARY_PATH="${BUILD_DIR}/libelf:${BUILD_DIR}/libebl:${BUILD_DIR}/libdw:${BUILD_DIR}/libasm" \
+               LC_ALL="C" \
+               emake check VERBOSE=1
+}
+
+multilib_src_install_all() {
+       einstalldocs
+       dodoc NOTES
+       # These build quick, and are needed for most tests, so don't
+       # disable their building when the USE flag is disabled.
+       if ! use utils; then
+               rm -rf "${ED}"/usr/bin || die
+       fi
+}
diff --git a/dev-libs/elfutils/files/elfutils-0.179-PaX-support.patch b/dev-libs/elfutils/files/elfutils-0.179-PaX-support.patch
new file mode 100644 (file)
index 0000000..5246d1a
--- /dev/null
@@ -0,0 +1,26 @@
+Add support for PaX ELF markings
+
+Patch by Kevin F. Quinn <kevquinn@gentoo.org>
+
+http://bugs.gentoo.org/115100
+
+--- a/libelf/elf.h
++++ b/libelf/elf.h
+@@ -721,6 +721,7 @@ typedef struct
+ #define PT_GNU_EH_FRAME       0x6474e550      /* GCC .eh_frame_hdr segment */
+ #define PT_GNU_STACK  0x6474e551      /* Indicates stack executability */
+ #define PT_GNU_RELRO  0x6474e552      /* Read-only after relocation */
++#define PT_PAX_FLAGS  0x65041580      /* Indicates PaX flag markings */
+ #define PT_LOSUNW     0x6ffffffa
+ #define PT_SUNWBSS    0x6ffffffa      /* Sun Specific segment */
+ #define PT_SUNWSTACK  0x6ffffffb      /* Stack segment */
+--- a/src/elflint.c
++++ b/src/elflint.c
+@@ -4493,6 +4493,7 @@ only executables, shared objects, and core files can have program headers\n"));
+       if (phdr->p_type >= PT_NUM && phdr->p_type != PT_GNU_EH_FRAME
+         && phdr->p_type != PT_GNU_STACK && phdr->p_type != PT_GNU_RELRO
++        && phdr->p_type != PT_PAX_FLAGS
+         && phdr->p_type != PT_GNU_PROPERTY
+         /* Check for a known machine-specific type.  */
+         && ebl_segment_type_name (ebl, phdr->p_type, NULL, 0) == NULL)