dev-ml/cmdliner: Bump to 1.0.0
authorAlexis Ballier <aballier@gentoo.org>
Thu, 2 Mar 2017 13:00:35 +0000 (14:00 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 2 Mar 2017 13:01:13 +0000 (14:01 +0100)
Package-Manager: Portage-2.3.4, Repoman-2.3.2

dev-ml/cmdliner/Manifest
dev-ml/cmdliner/cmdliner-1.0.0.ebuild [new file with mode: 0644]

index dd64b36bde2536dff57b4b257cf103413dbd9778..a27331ea4f0e7763f21c0f51d680b9090f64cfb7 100644 (file)
@@ -1 +1,2 @@
 DIST cmdliner-0.9.8.tbz 53249 SHA256 7dfaafdd88ec9d96abf8ded4c0ea7111948194400220a56e4bb44a1edfa4bd41 SHA512 6c71c360eaba7f7127e422a71a00a830a086f1d6750897bea0ebc1cc10f8fdaf9e9532d354abd84dbc6c5fcc1878f19d3f424fd9335e7226b625b63b51c89cab WHIRLPOOL 25739c09f78cc8ade6d0e5805f48eb14a6c42f0891832747caef44fc6135c81feaa0055b2874256bde2270753106c60accd50c24771333c2cb16913d9bd38c3d
+DIST cmdliner-1.0.0.tbz 46542 SHA256 3df9a78a1fa966ba0cfbc4195f0e4dc8d0ff67a4ed23aa1807ef47a0233ed6e7 SHA512 3fc87e49504167864ba4d81fde7bbaa01b7d58b06e2b68b36647857590f41fdc8b3bbd547418f8159b0e76628236b5c30301404b3d8d57e2ff3f082228eee73c WHIRLPOOL 866c6aa188787ec384ea099406e4b82998892ee7513339b0d5f514cc14e98a1f2cd0d8b2b6a852d9b80897aa60f182b75caf35f97d58e98b394f9d1c60fe3de8
diff --git a/dev-ml/cmdliner/cmdliner-1.0.0.ebuild b/dev-ml/cmdliner/cmdliner-1.0.0.ebuild
new file mode 100644 (file)
index 0000000..87ab3ba
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Declarative definition of command line interfaces for OCaml"
+HOMEPAGE="http://erratique.ch/software/cmdliner"
+SRC_URI="http://erratique.ch/software/${PN}/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+
+RDEPEND="
+       >=dev-lang/ocaml-4:=[ocamlopt?]
+       dev-ml/result:=
+"
+DEPEND="${RDEPEND}
+       dev-ml/topkg
+       dev-ml/ocamlbuild"
+
+src_compile() {
+       ocaml pkg/pkg.ml build \
+               --tests $(usex test true false) \
+               || die
+}
+
+src_test() {
+       ocaml pkg/pkg.ml test || die
+}
+
+src_install() {
+       # Can't use opam-installer here as it is an opam dep...
+       findlib_src_preinst
+       local nativelibs=""
+       use ocamlopt && nativelibs="$(echo _build/src/cmdliner.cm{x,xa,xs} _build/src/cmdliner.a)"
+       ocamlfind install cmdliner _build/pkg/META \
+               _build/src/cmdliner.mli _build/src/cmdliner.cm{a,i} ${nativelibs} || die
+       dodoc README.md CHANGES.md
+}