media-plugins/kodi-visualization-goom: 2.2.1 verison bump
authorCraig Andrews <candrews@gentoo.org>
Sun, 1 Mar 2020 02:30:09 +0000 (21:30 -0500)
committerCraig Andrews <candrews@gentoo.org>
Sun, 1 Mar 2020 02:35:31 +0000 (21:35 -0500)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Craig Andrews <candrews@gentoo.org>
media-plugins/kodi-visualization-goom/Manifest
media-plugins/kodi-visualization-goom/kodi-visualization-goom-2.2.1.ebuild [new file with mode: 0644]

index 752595fadbbfccec5980d4fbfe060362331061d8..6ffc425829ff940cc82193aaf56e47e339d5bbb2 100644 (file)
@@ -1,2 +1,3 @@
 DIST kodi-visualization-goom-2.1.0.tar.gz 8119409 BLAKE2B 4162201e4415df9b8dc4e22f40d6e9eb71e85804cfb6898d472e2d612a090e81041ed2bf3c1c7423012aff53cc239d25400948fad20e0ccf93fe59270491818e SHA512 5e2b4b2133938224506d94cf55cefb4aa77212e16b570900da33b84ea5de94bd4dcb3d161cc7d0d632353a9c9dd9a5925ce25b9c016cd13818944122c0806054
 DIST kodi-visualization-goom-2.2.0.tar.gz 8119581 BLAKE2B 4e02ac797420f6acf59c9a2c3ce8c185fcf64fc6306d9635401a026207b92eaa6465e492bcbae06b95130fc114c31529d31e5ddcc1e6eeb855f513a8689500e4 SHA512 b6ab828e76b4c1dae54b853cfdc2f31c143e93ec02e81492c3e7152174ce74553eb06720a448f1434a81e44d886ee2b5751c3674ce3f9a45e4988421ea5931ba
+DIST kodi-visualization-goom-2.2.1.tar.gz 8119580 BLAKE2B 92558e0560e0590bf7ed52e9506518e32ba80d5a71d10d1c622ec99186c8621a73308bb70cd95f97e86f6e2b6bf2920938e6692b5f080d98e2d457e95c1ab958 SHA512 f93f602e77e754545a58dc9f4ff92c850754503db853b47acbb36468263059919e827e8ffeafe261eca7f6e9c8b563a83787914fa8669bfb50f66aa5c551fbc6
diff --git a/media-plugins/kodi-visualization-goom/kodi-visualization-goom-2.2.1.ebuild b/media-plugins/kodi-visualization-goom/kodi-visualization-goom-2.2.1.ebuild
new file mode 100644 (file)
index 0000000..91e5232
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake kodi-addon
+
+DESCRIPTION="Goom visualizer for Kodi"
+HOMEPAGE="https://github.com/notspiff/visualization.goom"
+SRC_URI=""
+
+case ${PV} in
+9999)
+       SRC_URI=""
+       EGIT_REPO_URI="https://github.com/notspiff/visualization.goom.git"
+       inherit git-r3
+       ;;
+*)
+       KEYWORDS="~amd64 ~x86"
+       CODENAME="Leia"
+       SRC_URI="https://github.com/notspiff/visualization.goom/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}/visualization.goom-${PV}-${CODENAME}"
+       ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+       =media-tv/kodi-18*
+       virtual/opengl
+       "
+
+RDEPEND="
+       ${DEPEND}
+       "