games-roguelike/nethack: Update to the newest PR version
authorLuis Ressel <aranea@aixah.de>
Tue, 21 Aug 2018 21:11:34 +0000 (23:11 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 23 Aug 2018 20:10:46 +0000 (22:10 +0200)
Accidentally merged an old version.  Fixing it up.

Pull-Request: https://github.com/gentoo/gentoo/pull/9661

games-roguelike/nethack/nethack-3.6.1.ebuild

index 3c6526d8c1ca66f8f3395a07800cec8b162d7991..b965ddbd5ef36b6d0bb350ed52c95238e6c2ecc8 100644 (file)
@@ -118,9 +118,10 @@ pkg_postinst() {
        # by comparing the mtimes of save files and its own binary. This would require admin interaction even
        # during upgrades which don't change the file format, so we'll just touch the files and warn the admin
        # manually in case of compatibility issues.
-       ( shopt -s nullglob
+       (
+               shopt -s nullglob
                local saves=( bones* save/* )
-               test ${#saves[@]} -gt 0 && touch -c "${saves[@]}"
+               [[ -n "${saves[*]}" ]] && touch -c "${saves[@]}"
        ) # non-fatal
 
        elog "A minimal default .nethackrc has been placed in /etc/skel/"