sys-block/scsiping: EAPI7 bump
authorRobin H. Johnson <robbat2@gentoo.org>
Fri, 8 Nov 2019 00:43:23 +0000 (16:43 -0800)
committerRobin H. Johnson <robbat2@gentoo.org>
Fri, 8 Nov 2019 00:43:37 +0000 (16:43 -0800)
Fixes: https://bugs.gentoo.org/show_bug.cgi?id=697200
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
sys-block/scsiping/scsiping-0.0.1-r1.ebuild [new file with mode: 0644]

diff --git a/sys-block/scsiping/scsiping-0.0.1-r1.ebuild b/sys-block/scsiping/scsiping-0.0.1-r1.ebuild
new file mode 100644 (file)
index 0000000..4879d3b
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="SCSIPing pings a host on the SCSI-chain"
+HOMEPAGE="https://www.vanheusden.com/Linux/"
+SRC_URI="https://www.vanheusden.com/Linux/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+       sed -i -e '/strip scsiping/d' "${S}"/Makefile
+       default
+}
+
+src_compile() {
+       emake DEBUG='' CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+       dosbin scsiping
+}
+
+pkg_postinst() {
+       ewarn "WARNING: using scsiping on a device with mounted partitions may be hazardous to your system!"
+}