dev-python/cliapp: Version bump to 1.20180812.1
authorMatt Turner <mattst88@gentoo.org>
Thu, 11 Jul 2019 23:23:59 +0000 (16:23 -0700)
committerMatt Turner <mattst88@gentoo.org>
Fri, 12 Jul 2019 05:40:19 +0000 (22:40 -0700)
A bunch of things too:
- Port to EAPI=7
- Fix incorrect license
- HTTPS homepage

Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-python/cliapp/Manifest
dev-python/cliapp/cliapp-1.20180812.1.ebuild [new file with mode: 0644]

index 15f65752e58e3fe6dd184e1e6f1e4bbe948416c0..9fca9db6b47cefb58268f384ec5bb815c9d2ada3 100644 (file)
@@ -1 +1,2 @@
 DIST cliapp-1.20170823.tar.gz 54601 BLAKE2B b2a414aa77de872045983a9776e2afd55fa18a5997306f1e532b4b2bb413eedd6a868fe52f91565829be09f42808f745bfefd94ab307a61eb39f64805c3d7cdd SHA512 f66e35faf2cf64d56bfac546cde7e4818d54e4eded9841c788eb7800ea87211594cd9921d6e5f7d2c2b69b031823ab85aba92b09ea204f3b89f060b353a2d311
+DIST cliapp-1.20180812.1.tar.gz 55134 BLAKE2B 184fb65751ce9960f98a62beaeb7ecd4f55cc8bfc9f5dea568900b7be5f5b42277d5ea8b23c20f73c73ab67d605234fe0a5e28660647a985c0de19de0b625ff1 SHA512 61b6f36abb3eefb1c52752e8eb1048c1629c86aa269fcac9c5ee4d875031a040c9c3824131f953dc9bfe568e9e99202750c2e8c11791afe3fce1c1872ce2510d
diff --git a/dev-python/cliapp/cliapp-1.20180812.1.ebuild b/dev-python/cliapp/cliapp-1.20180812.1.ebuild
new file mode 100644 (file)
index 0000000..2b48b8a
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Framework for Unix-like command line programs"
+HOMEPAGE="https://liw.fi/cliapp/"
+SRC_URI="http://git.liw.fi/${PN}/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE=""
+
+DEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_test() {
+       addwrite /proc/self/comm
+       distutils-r1_src_test
+}
+
+python_test() {
+       "${EPYTHON}" -m unittest discover -v -p '*_tests.py' || die
+}